]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance-image: Add explict dependency on do_unpack
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Nov 2012 21:37:23 +0000 (21:37 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 24 Nov 2012 15:12:04 +0000 (15:12 +0000)
The code called by do_rootfs explicitly needs the code obtained during
do_unpack. If built from sstate, it might not be present so we ensure
it is by adding an explicit dependency. This fixes build failures when
building from sstate.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/images/build-appliance-image.bb

index 2bcfe8c50859bc5d29378d3e861935284a7a3d34..35c6abebec7906f460633c5bcc9556d8f47f100f 100644 (file)
@@ -68,6 +68,8 @@ fakeroot do_populate_poky_src () {
 
 IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "
 
+addtask rootfs after do_unpack
+
 python () {
        # Ensure we run these usually noexec tasks
        d.delVarFlag("do_fetch", "noexec")