]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng-modules: fix compliation error with 3.2.x -stable kernels
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 19 Mar 2012 17:53:57 +0000 (13:53 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Mar 2012 20:19:25 +0000 (20:19 +0000)
recent -stable kernels have their own fallback definition of is_compat_task

   #define is_compat_task() (0)

To protect against this double definition of is_compat_task we can check
to see if it is already defined, and skip the lttng variant.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/lttng-2.0/lttng-modules/lttng-sycalls-protect-is_compat_task-from-redefiniti.patch [new file with mode: 0644]
meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb

diff --git a/meta/recipes-kernel/lttng-2.0/lttng-modules/lttng-sycalls-protect-is_compat_task-from-redefiniti.patch b/meta/recipes-kernel/lttng-2.0/lttng-modules/lttng-sycalls-protect-is_compat_task-from-redefiniti.patch
new file mode 100644 (file)
index 0000000..0056633
--- /dev/null
@@ -0,0 +1,41 @@
+From 415a1a678cb2fcf603f9777f2c7b71c1e38f8101 Mon Sep 17 00:00:00 2001
+From: Bruce Ashfield <bruce.ashfield@windriver.com>
+Date: Mon, 19 Mar 2012 13:30:31 -0400
+Subject: [PATCH] lttng-sycalls: protect is_compat_task from redefinition
+
+recent -stable kernels have their own fallback definition of is_compat_task
+
+   #define is_compat_task() (0)
+
+To protect against this double definition of is_compat_task we can check
+to see if it is already defined, and skip the lttng variant.
+
+Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
+---
+ lttng-syscalls.c |    4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/lttng-syscalls.c b/lttng-syscalls.c
+index 9de3c07..80d0f05 100644
+--- a/lttng-syscalls.c
++++ b/lttng-syscalls.c
+@@ -17,12 +17,16 @@
+ #include "ltt-events.h"
+ #ifndef CONFIG_COMPAT
++
++#ifndef is_compat_task
+ static inline int is_compat_task(void)
+ {
+       return 0;
+ }
+ #endif
++#endif
++
+ static
+ void syscall_entry_probe(void *__data, struct pt_regs *regs, long id);
+-- 
+1.7.5.4
+
index fa7bbec8d2a190c7c5314160eaba7296f9ded249..4c78f36ba05fa86cbca85c8646414edd5491407a 100644 (file)
@@ -15,7 +15,8 @@ PV = "2.0.pre11+git${SRCREV}"
 PR = "r0"
 
 SRC_URI = "git://git.lttng.org/lttng-modules.git;protocol=git \
-           file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
+           file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
+           file://lttng-sycalls-protect-is_compat_task-from-redefiniti.patch"
 
 export INSTALL_MOD_DIR="kernel/lttng-modules"
 export KERNEL_SRC="${STAGING_KERNEL_DIR}"