]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: add patch to solve libcrypt incompatibility
authorCharles-Antoine Couret <charles-antoine.couret@essensium.com>
Fri, 6 Apr 2018 12:53:54 +0000 (14:53 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 May 2018 08:52:13 +0000 (09:52 +0100)
Add Perl's patch submitted to upstream to be compiled along with glibc with libcrypt split.

(From OE-Core rev: 79703d83790a2973fefdb0e12e125b5f17e98cdf)

Signed-off-by: Charles-Antoine Couret <charles-antoine.couret@essensium.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/perl/perl-native_5.24.1.bb
meta/recipes-devtools/perl/perl/perl-5.26.1-guard_old_libcrypt_fix.patch [new file with mode: 0644]
meta/recipes-devtools/perl/perl_5.24.1.bb

index 6c56a7d70139eb14a9d9d23f90c99e622f4c688e..2f5dffd65b75c912b0f531767e4807f600e0b711 100644 (file)
@@ -16,6 +16,7 @@ SRC_URI += "\
            file://dynaloaderhack.patch \
            file://perl-PathTools-don-t-filter-out-blib-from-INC.patch \
            file://0001-Configure-Remove-fstack-protector-strong-for-native-.patch \
+           file://perl-5.26.1-guard_old_libcrypt_fix.patch \
           "
 
 SRC_URI[md5sum] = "af6a84c7c3e2b8b269c105a5db2f6d53"
diff --git a/meta/recipes-devtools/perl/perl/perl-5.26.1-guard_old_libcrypt_fix.patch b/meta/recipes-devtools/perl/perl/perl-5.26.1-guard_old_libcrypt_fix.patch
new file mode 100644 (file)
index 0000000..bb6c573
--- /dev/null
@@ -0,0 +1,28 @@
+commit 13e70b397dcb0d1bf4a869b670f041c1d7b730d0
+Author: Bjรถrn Esser <besser82@fedoraproject.org>
+Date:   Sat Jan 20 20:22:53 2018 +0100
+
+    pp: Guard fix for really old bug in glibc libcrypt
+
+Upstream-Status: Pending
+Signed-off-by Richard Purdie <richard.purdie@linuxfoundation.org>
+
+diff --git a/pp.c b/pp.c
+index d50ad7ddbf..6510c7b15c 100644
+--- a/pp.c
++++ b/pp.c
+@@ -3650,8 +3650,12 @@ PP(pp_crypt)
+ #if defined(__GLIBC__) || defined(__EMX__)
+       if (PL_reentrant_buffer->_crypt_struct_buffer) {
+           PL_reentrant_buffer->_crypt_struct_buffer->initialized = 0;
+-          /* work around glibc-2.2.5 bug */
++#if (defined(__GLIBC__) && __GLIBC__ == 2) && \
++    (defined(__GLIBC_MINOR__) && __GLIBC_MINOR__ >= 2 && __GLIBC_MINOR__ < 4)
++          /* work around glibc-2.2.5 bug, has been fixed at some
++           * time in glibc-2.3.X */
+           PL_reentrant_buffer->_crypt_struct_buffer->current_saltbits = 0;
++#endif
+       }
+ #endif
+     }
+
index b55d2223e284d6cf92c7520a2817a921f07b1033..8c5dd82207d05e6a7cd534a54ef125d83aa736a9 100644 (file)
@@ -65,6 +65,7 @@ SRC_URI += " \
         file://perl-errno-generation-gcc5.patch \
         file://perl-fix-conflict-between-skip_all-and-END.patch \
         file://perl-test-customized.patch \
+        file://perl-5.26.1-guard_old_libcrypt_fix.patch \
 "
 
 # Fix test case issues