]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs: fix test f_detect_junk print error msg
authorChangqing Li <changqing.li@windriver.com>
Fri, 12 Oct 2018 02:21:12 +0000 (10:21 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 12 Oct 2018 07:44:09 +0000 (08:44 +0100)
This test need to check config.h, so install it
to fix below err msg:

grep: ../lib/config.h: No such file or directory
./test/f_detect_junk/script: line 3: [: : integer expression expected
f_detect_junk: detect non-fs file data: ok

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/e2fsprogs/e2fsprogs_1.44.3.bb

index 6c65e95dd82832bcfbe221b3e3b898a1267447c5..45c96742c7e8bd4845260f2d1be5e1983994778d 100644 (file)
@@ -129,4 +129,7 @@ do_install_ptest() {
        find "${D}${PTEST_PATH}" -type f \
            \( -name 'Makefile' -o -name 'Makefile.in' -o -name '*.o' -o -name '*.c' -o -name '*.h' \)\
            -exec  rm -f {} +
+
+        install -d ${D}${PTEST_PATH}/lib
+        install -m 0644 ${B}/lib/config.h  ${D}${PTEST_PATH}/lib/
 }