]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add madplay to -extras and create an extras image to include apps in extras
authorRichard Purdie <richard@openedhand.com>
Tue, 4 Jul 2006 20:20:45 +0000 (20:20 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 4 Jul 2006 20:20:45 +0000 (20:20 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@502 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded-extras/packages/libid3tag/libid3tag_0.15.0b.bb [new file with mode: 0644]
openembedded-extras/packages/libmad/libmad_0.15.0b.bb [new file with mode: 0644]
openembedded-extras/packages/madplay/madplay_0.15.2b.bb [new file with mode: 0644]
openembedded-extras/packages/meta/oh-image-extras.bb [new file with mode: 0644]
openembedded-extras/packages/meta/task-oh-extras.bb [new file with mode: 0644]

diff --git a/openembedded-extras/packages/libid3tag/libid3tag_0.15.0b.bb b/openembedded-extras/packages/libid3tag/libid3tag_0.15.0b.bb
new file mode 100644 (file)
index 0000000..e47c00e
--- /dev/null
@@ -0,0 +1,19 @@
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+DEPENDS = "zlib"
+DESCRIPTION = "Library for interacting with ID3 tags."
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libid3tag-${PV}.tar.gz "
+S = "${WORKDIR}/libid3tag-${PV}"
+
+inherit autotools 
+
+EXTRA_OECONF = "-enable-speed"
+
+do_stage() {
+       oe_libinstall -so libid3tag ${STAGING_LIBDIR}
+        install -m 0644 id3tag.h ${STAGING_INCDIR}
+}
diff --git a/openembedded-extras/packages/libmad/libmad_0.15.0b.bb b/openembedded-extras/packages/libmad/libmad_0.15.0b.bb
new file mode 100644 (file)
index 0000000..b3614db
--- /dev/null
@@ -0,0 +1,26 @@
+DESCRIPTION = "MPEG Audio Decoder Library"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+DEPENDS = "libid3tag"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libmad-${PV}.tar.gz"
+S = "${WORKDIR}/libmad-${PV}"
+
+inherit autotools 
+
+EXTRA_OECONF = "-enable-speed --enable-shared"
+# The ASO's don't take any account of thumb...
+EXTRA_OECONF_append_thumb = " --disable-aso --enable-fpm=default"
+
+do_configure_prepend () {
+#      damn picky automake...
+       touch NEWS AUTHORS ChangeLog
+}
+
+do_stage() {
+       oe_libinstall -so libmad ${STAGING_LIBDIR}
+       install -m 0644 mad.h ${STAGING_INCDIR}
+}
diff --git a/openembedded-extras/packages/madplay/madplay_0.15.2b.bb b/openembedded-extras/packages/madplay/madplay_0.15.2b.bb
new file mode 100644 (file)
index 0000000..ba2d184
--- /dev/null
@@ -0,0 +1,13 @@
+DESCRIPTION = "Madplay is a command-line MPEG audio decoder and player"
+MAINTAINER = "Maciej Swiniarski <luzik@gda.pl>"
+SECTION = "console/multimedia"
+DEPENDS = "libmad"
+LICENSE = "GPL"
+AUTHOR = "Robert Leslie <rob@mars.org>"
+HOMEPAGE = "http://www.mars.org/home/rob/proj/mpeg/"
+
+SRC_URI = "ftp://ftp.mars.org/pub/mpeg/${PN}-${PV}.tar.gz"
+
+inherit autotools
+
+FILES_${PN} = "${bindir}/madplay"
diff --git a/openembedded-extras/packages/meta/oh-image-extras.bb b/openembedded-extras/packages/meta/oh-image-extras.bb
new file mode 100644 (file)
index 0000000..0b2ac43
--- /dev/null
@@ -0,0 +1,27 @@
+PR = "r9"
+
+export IMAGE_BASENAME = "oh-extras"
+
+GUI_MACHINE_CLASS ?= "none"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+DEPENDS = "\
+    task-oh \
+    task-oh-extras"
+    
+RDEPENDS = "\
+    task-oh-boot \
+    task-oh-boot-extras \
+    task-oh-base \
+    task-oh-standard \
+    task-oh-testapps \
+    task-oh-devtools \
+    task-oh-extraapps \
+    ${XSERVER} "
+
+export IPKG_INSTALL = "${RDEPENDS}"
+#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
+
+inherit image_ipk
+LICENSE = MIT
diff --git a/openembedded-extras/packages/meta/task-oh-extras.bb b/openembedded-extras/packages/meta/task-oh-extras.bb
new file mode 100644 (file)
index 0000000..6c5b9a9
--- /dev/null
@@ -0,0 +1,10 @@
+PACKAGES = "task-oh-extraapps"
+DESCRIPTION = "Extras Tasks for OpenedHand Poky"
+MAINTAINER = "Richard Purdie <richard@openedhand.com>"
+PR = "r0"
+
+ALLOW_EMPTY = "1"
+
+RDEPENDS_task-oh-extraapps = "\
+    madplay \
+    mc"