]> code.ossystems Code Review - openembedded-core.git/commitdiff
initrdscripts: fix udevd in the live boot init scripts
authorRoss Burton <ross.burton@intel.com>
Mon, 12 Nov 2012 16:18:35 +0000 (16:18 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 Nov 2012 22:30:19 +0000 (22:30 +0000)
udevd moved location and isn't in $PATH anymore, so use an absolute path to
start it.

The control socket path moved too, so mkdir the directory it's in.

Mounts the new devtmpfs on /dev device tree.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Alexandru Damian <alexandru.damian@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/initrdscripts/files/init-live.sh
meta/recipes-core/initrdscripts/initramfs-framework/udev
meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb

index 5682fd18c17ecf18208d7c8e4d85144baf9ba058..c591f0d3862355661609030b074fb3a3eac56016 100644 (file)
@@ -14,12 +14,14 @@ early_setup() {
     mkdir -p /sys
     mount -t proc proc /proc
     mount -t sysfs sysfs /sys
+    mount -t devtmpfs none /dev
 
     # support modular kernel
     modprobe isofs 2> /dev/null
 
     mkdir -p /run
-    udevd --daemon
+    mkdir -p /var/run
+    /lib/udev/udevd --daemon
     udevadm trigger --action=add
 }
 
index 9ea8aa3641e4ab2c6c241ce51679556394c1d9eb..15a1d5ba0696da4e30d3cb783fc8a42c26cc4198 100644 (file)
@@ -3,8 +3,8 @@
 # Licensed on MIT
 
 udev_enabled() {
-       if [ ! -e /sbin/udevd ]; then
-               debug "/sbin/udev doesn't exist"
+       if [ ! -e /lib/udev/udevd ]; then
+               debug "/lib/udev/udev doesn't exist"
                return 1
        fi
 
@@ -14,7 +14,7 @@ udev_enabled() {
 udev_run() {
        mkdir -p /run
 
-       udevd --daemon > /dev/null
+       /lib/udev/udevd --daemon > /dev/null
        udevadm trigger --action=add
        udevadm settle
 
index 58e41d4d4cce5d873bebb104aa2799bb83427ab5..45d6592bc39a23f9487de306dc0abdfc7ece7e7f 100644 (file)
@@ -3,6 +3,8 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 RDEPENDS = "busybox"
 
+PR = "r1"
+
 inherit allarch
 
 SRC_URI = "file://init \
index 137a40106ee778487fdf0e8076449a1aab880e89..55a8600ba4960fa2f5dfc6ca25829d701b35fe23 100644 (file)
@@ -5,7 +5,7 @@ RDEPENDS = "udev"
 DEPENDS = "virtual/kernel"
 SRC_URI = "file://init-live.sh"
 
-PR = "r10"
+PR = "r11"
 
 do_compile() {
        #if grep -q "CONFIG_UNION_FS=y" ${STAGING_KERNEL_DIR}/.config; then