]> code.ossystems Code Review - openembedded-core.git/commitdiff
createrepo-c: fix createrepo-c failed in nativesdk
authorhongxu <hongxu.jia@windriver.com>
Wed, 4 Aug 2021 13:08:35 +0000 (21:08 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 Aug 2021 07:51:17 +0000 (08:51 +0100)
In sdk, call createrepo-c failed with:
...
$ createrepo_c --update ./test_repo/rpm
Directory walk started Critical: Failed to detect compression for file
./test_repo/rpm/cortexa72/hello-2.10-r0.cortexa72.rpm: magic_load() failed: could not find any valid magic files!
...

Since commit [ea666fbc74 createrepo-c: set path to magic database for
native and nativesdk] applied, the MAGIC is incorrectly assigned.

The variable datadir will be expanded automatically for nativesdk,
do not need to add prefix ${SDKPATHNATIVE} to MAGIC

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb

index 6313afc108daad0544a41cd261511843d324e1a7..500b508d7247aad7f198aa53d6d8ff508dc98707 100644 (file)
@@ -33,8 +33,8 @@ do_install:append:class-native() {
 do_install:append:class-nativesdk() {
         create_wrapper ${D}/${bindir}/createrepo_c \
                 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
-                MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+                MAGIC=${datadir}/misc/magic.mgc
         create_wrapper ${D}/${bindir}/modifyrepo_c \
-                MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+                MAGIC=${datadir}/misc/magic.mgc
         rm -rf ${D}/etc
 }