]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox/packagegroups: Break out the busybox-syslog dependency
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Sep 2018 22:40:47 +0000 (23:40 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Sep 2018 16:48:32 +0000 (17:48 +0100)
The busybox-syslog rrecomends is proving tricky as it gets pulled in early and
there are conflicts between its use of update-alternatives and busybox needing
to provide those things.

We already have recipes using BAD_RRECOMMENDS to remove this dependency, it probably
makes sense to spell it out explicitly and allow it to be overridden more easily.

This patch does this, dropping the now unneeded BAD_RRECOMMENDS. It preserves
the dependency as a recommendation for now, further cleanup may allow simplication
of that.

This unbreaks certain build failures on the autobuilder, more as a workaround but
is a change we probably want to make anyway.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/distro/include/default-providers.inc
meta/recipes-core/busybox/busybox.inc
meta/recipes-core/images/core-image-minimal-initramfs.bb
meta/recipes-core/images/core-image-tiny-initramfs.bb
meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb
meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb
meta/recipes-core/initrdscripts/initramfs-module-install-efi_1.0.bb
meta/recipes-core/initrdscripts/initramfs-module-install_1.0.bb
meta/recipes-core/packagegroups/packagegroup-core-boot.bb

index 779b03d50cfed610e9331f9f613d490a72c31a08..019ceeb290abbb7c8075e1a03e2eda5346da74fc 100644 (file)
@@ -25,6 +25,7 @@ VIRTUAL-RUNTIME_alsa-state ?= "alsa-state"
 VIRTUAL-RUNTIME_getopt ?= "util-linux-getopt"
 VIRTUAL-RUNTIME_base-utils ?= "busybox"
 VIRTUAL-RUNTIME_base-utils-hwclock ?= "busybox-hwclock"
+VIRTUAL-RUNTIME_base-utils-syslog ?= "busybox-syslog"
 
 #
 # Default recipe providers
index 2ad29a7e72ec1f61e2f6a988ae195721aac74e55..e1fba4243a13ac408ba736179e52148c617485a7 100644 (file)
@@ -47,7 +47,7 @@ RCONFLICTS_${PN}-syslog = "rsyslog sysklogd syslog-ng"
 
 CONFFILES_${PN}-mdev = "${sysconfdir}/mdev.conf"
 
-RRECOMMENDS_${PN} = "${PN}-syslog ${PN}-udhcpc"
+RRECOMMENDS_${PN} = "${PN}-udhcpc"
 
 RDEPENDS_${PN} = "${@["", "busybox-inittab"][(d.getVar('VIRTUAL-RUNTIME_init_manager') == 'busybox')]}"
 
index 6de860e43a833d40c34bd9afee35637a0ef2f67a..7df8ab1ebd8ed595a6922b5f83b42dc00d2d39d8 100644 (file)
@@ -27,7 +27,5 @@ inherit core-image
 IMAGE_ROOTFS_SIZE = "8192"
 IMAGE_ROOTFS_EXTRA_SPACE = "0"
 
-BAD_RECOMMENDATIONS += "busybox-syslog"
-
 # Use the same restriction as initramfs-live-install
 COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
index 51d08a0cd1c2808a3c79bf2008d58f0add53a872..d7f97f3a170cfe82325c60be5eb8a1d9b2d1d7e9 100644 (file)
@@ -23,8 +23,6 @@ inherit core-image
 IMAGE_ROOTFS_SIZE = "8192"
 IMAGE_ROOTFS_EXTRA_SPACE = "0"
 
-BAD_RECOMMENDATIONS += "busybox-syslog"
-
 # Use the same restriction as initramfs-live-install
 COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
 
index 6337b998acc349a3e0cc920e291d4eb8a0a1e751..660343eafa23f35c85b73b0cb16fa7beb4f5cf0f 100644 (file)
@@ -2,6 +2,7 @@ SUMMARY = "Modular initramfs system"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_base-utils}"
+RRECOMMENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
 
 PR = "r4"
 
index f588a1077bfc852de9fc411eae8acf4f5cdc7a5c..cc842ae8b712ebf5c4657a55741aa8894e2b7a98 100644 (file)
@@ -6,6 +6,7 @@ SRC_URI = "file://init-install-efi.sh"
 PR = "r1"
 
 RDEPENDS_${PN} = "parted e2fsprogs-mke2fs dosfstools util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
+RRECOMMENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
 
 S = "${WORKDIR}"
 
index 9222d57c1aeb1bf65946ced183653c8a7ba87564..48fc0c4a7695b77ba4294191c60a2c138cdb4817 100644 (file)
@@ -8,6 +8,7 @@ PR = "r9"
 S = "${WORKDIR}"
 
 RDEPENDS_${PN} = "grub parted e2fsprogs-mke2fs util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
+RRECOMMENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
 
 do_install() {
         install -m 0755 ${WORKDIR}/init-install.sh ${D}/install.sh
index 78a61cde25f26256ca35595310d132a0b6bb6e6f..523138cff361ed49296be83c766d4f7f26a8fa99 100644 (file)
@@ -2,6 +2,7 @@ SUMMARY = "initramfs-framework module for EFI installation option"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 RDEPENDS_${PN} = "initramfs-framework-base parted e2fsprogs-mke2fs dosfstools util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
+RRECOMMENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
 
 PR = "r4"
 
index 04e90cd302c411be5545a2a0afcb69d7be1b49a6..56898e824f319ea00b1ec79b24537148e7263d92 100644 (file)
@@ -2,6 +2,7 @@ SUMMARY = "initramfs-framework module for installation option"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 RDEPENDS_${PN} = "initramfs-framework-base grub parted e2fsprogs-mke2fs util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
+RRECOMMENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
 
 # The same restriction as grub
 COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
index 76cd7fc4ebfb967ad2487584240260f3421e1866..8dc445dc8f6f3c5bc3ffc1d5ed6fcb5830aef9a5 100644 (file)
@@ -46,4 +46,5 @@ RDEPENDS_${PN} = "\
     ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
 
 RRECOMMENDS_${PN} = "\
+    ${VIRTUAL-RUNTIME_base-utils-syslog} \
     ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"