]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-hypothesis: upgrade 6.13.7 -> 6.13.14
authorTim Orling <ticotimo@gmail.com>
Sun, 6 Jun 2021 22:20:14 +0000 (15:20 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Jun 2021 21:59:00 +0000 (22:59 +0100)
Add RDEPENDS on python3-unittest

Upstream release notes:

6.13.14
  This patch improves the :func:`~hypothesis.strategies.tuples` strategy
  type annotations, to preserve the element types for up to length-five
  tuples (:issue:`3005`).

  As for :func:`~hypothesis.strategies.one_of`, this is the best we can do
  before a `planned extension <https://mail.python.org/archives/list/typing-sigpython.org/thread/LOQFV3IIWGFDB7F5BDX746EZJG4VVBI3/>`__
  to :pep:`646` is released, hopefully in Python 3.11.

6.13.13
  This patch teaches :doc:`the Ghostwriter <ghostwriter>` how to find
  :np-ref:`custom ufuncs <ufuncs.html>` from *any* module that defines them,
  and that ``yaml.unsafe_load()`` does not undo ``yaml.safe_load()``.

6.13.12
  This patch reduces the amount of internal code excluded from our test suite's
  code coverage checks.

  There is no user-visible change.

6.13.11
  This patch removes some old internal helper code that previously existed
  to make Python 2 compatibility easier.

  There is no user-visible change.

6.13.10
  This release adjusts some internal code to help make our test suite more
  reliable.

  There is no user-visible change.

6.13.9
  This patch cleans up some internal code related to filtering strategies.

  There is no user-visible change.

6.13.8
  This patch slightly improves the performance of some internal code for
  generating integers.

Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-hypothesis_6.13.14.bb [moved from meta/recipes-devtools/python/python3-hypothesis_6.13.7.bb with 77% similarity]

similarity index 77%
rename from meta/recipes-devtools/python/python3-hypothesis_6.13.7.bb
rename to meta/recipes-devtools/python/python3-hypothesis_6.13.14.bb
index 7688ff6d18c7f0f2a6706c566bd1878b96ebb51e..150dc8a5d6b158f970b1db4cf61e75bd055b4225 100644 (file)
@@ -7,8 +7,8 @@ PYPI_PACKAGE = "hypothesis"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "262bb8cee0293ad06c453e78cf89bddcb613b91f82ea5587f3787611ee62861b"
+SRC_URI[sha256sum] = "36ef2d58f600be2973f694f45a55a5502de705d7594f9cf841276aec9082c414"
 
-RDEPENDS_${PN} += "python3-attrs python3-core python3-sortedcontainers"
+RDEPENDS_${PN} += "python3-attrs python3-core python3-sortedcontainers python3-unittest"
 
 BBCLASSEXTEND = "native nativesdk"