]> code.ossystems Code Review - openembedded-core.git/commitdiff
apt: fix build issue with gcc dso linking change
authorNitin A Kamble <nitin.a.kamble@intel.com>
Thu, 20 Jan 2011 00:41:01 +0000 (16:41 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 20 Jan 2011 21:37:05 +0000 (21:37 +0000)
All the libraries needs to be specified explicitely with the new gcc dso
linking change patch. This was causing build errors for this
recipe. Specifying the libpthread library explicitely for linking to work
without errors.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-devtools/apt/apt-0.7.14/dso_linking_change_build_fix.patch [new file with mode: 0644]
meta/recipes-devtools/apt/apt_0.7.14.bb

diff --git a/meta/recipes-devtools/apt/apt-0.7.14/dso_linking_change_build_fix.patch b/meta/recipes-devtools/apt/apt-0.7.14/dso_linking_change_build_fix.patch
new file mode 100644 (file)
index 0000000..b69849f
--- /dev/null
@@ -0,0 +1,25 @@
+after gcc linking has changed, all the libraries must be explicitely specified 
+This patch avoids these linking errors:
+
+Building program /build_disk/poky_build/build0/tmp/work/i586-poky-linux/apt-0.7.14-r4/apt-0.7.14/bin/methods/https
+/build_disk/poky_build/build0/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.5.1/ld: <86>: invalid DSO for symbol `pthread_cancel@@GLIBC_2.0' definition
+/build_disk/poky_build/build0/tmp/sysroots/i586-poky-linux/lib/libpthread.so.0: could not read symbols: Bad value
+collect2: ld returned 1 exit status
+make[2]: *** [/build_disk/poky_build/build0/tmp/work/i586-poky-linux/apt-0.7.14-r4/apt-0.7.14/bin/methods/https] Error 1
+
+Nitin A Kamble <nitin.a.kamble@intel.com>
+Date: 2011/01/19
+
+Index: apt-0.7.14/methods/makefile
+===================================================================
+--- apt-0.7.14.orig/methods/makefile   2008-05-28 06:22:14.000000000 -0700
++++ apt-0.7.14/methods/makefile        2011-01-19 16:30:07.369010214 -0800
+@@ -54,7 +54,7 @@
+ # The https method
+ PROGRAM=https
+-SLIBS = -lapt-pkg -lcurl
++SLIBS = -lapt-pkg -lcurl -lpthread
+ LIB_MAKES = apt-pkg/makefile
+ SOURCE = https.cc
+ include $(PROGRAM_H)
index d2bcde5a22ec65e72610fffc38ce9411051ccaba..b9b278b17c9240d775c2bf0c13dad4bf2e8b935c 100644 (file)
@@ -3,10 +3,11 @@ RDEPENDS_${PN} = "dpkg"
 LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=0636e73ff0215e8d672dc4c32c317bb3"
 require apt.inc
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI += "file://nodoc.patch \
-           file://includes-fix.patch"
+           file://includes-fix.patch \
+           file://dso_linking_change_build_fix.patch "
 
 SRC_URI[md5sum] = "19efa18fb1ef20c58b9b44e94258b814"
 SRC_URI[sha256sum] = "8fc06effaf8a4e4333308eedcdc6840f1c8056f2e924210f151dfc076bcd4045"