]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: add PACKAGECONFIG for bluez
authorRobert Yang <liezhi.yang@windriver.com>
Mon, 11 May 2015 07:46:56 +0000 (00:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 14 May 2015 10:41:13 +0000 (11:41 +0100)
Fixed:
net.c:65:34: fatal error: bluetooth/bluetooth.h: No such file or directory
 # include <bluetooth/bluetooth.h>
                                  ^
compilation terminated.

And use "??=" rather than "?=" for PACKAGECONFIG.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-devtools/strace/strace_4.10.bb

index 07a1076bbaddca660ec509a17751053a2501b9f1..20b7e3d0a578cbc225eed4beb1071b14f6963f7a 100644 (file)
@@ -17,14 +17,18 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
 SRC_URI[md5sum] = "107a5be455493861189e9b57a3a51912"
 SRC_URI[sha256sum] = "e6180d866ef9e76586b96e2ece2bfeeb3aa23f5cc88153f76e9caedd65e40ee2"
 
-inherit autotools ptest
+inherit autotools ptest bluetooth
 RDEPENDS_${PN}-ptest += "make coreutils grep gawk"
 
-PACKAGECONFIG_class-target ?= "libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+PACKAGECONFIG_class-target ??= "\
+    libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
+"
 
 PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
 PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
 PACKAGECONFIG[libunwind] = "--with-libunwind, --without-libunwind, libunwind"
+PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
 
 TESTDIR = "tests"