]> code.ossystems Code Review - openembedded-core.git/commitdiff
rsync: upgrade to version 3.0.7
authorQing He <qing.he@intel.com>
Tue, 6 Jul 2010 08:56:06 +0000 (16:56 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 16 Jul 2010 15:25:17 +0000 (16:25 +0100)
from 2.6.9
2.6.9 is also preserved as the last known GPL2 version

changes:
  - 3.0.7 has some new change to the autotools scripts, it uses
    and configure.sh and checks its existence in Makefile, adapt
    this by adding do_configure_{prepend,append}
  - aclocal.m4 now also contains custom m4 macros, add acinclude.m4
    in the files/
  - add popt as build dependency. Besides, rsync can also link to
    libacl and libattr. Possibly need to add them in the future, for
    now, document the dependency

Signed-off-by: Qing He <qing.he@intel.com>
meta/packages/rsync/files/acinclude.m4 [new file with mode: 0644]
meta/packages/rsync/rsync.inc [new file with mode: 0644]
meta/packages/rsync/rsync_2.6.9.bb
meta/packages/rsync/rsync_3.0.7.bb [new file with mode: 0644]

diff --git a/meta/packages/rsync/files/acinclude.m4 b/meta/packages/rsync/files/acinclude.m4
new file mode 100644 (file)
index 0000000..735b41d
--- /dev/null
@@ -0,0 +1,95 @@
+dnl verbatim renamed from aclocal.m4 in rsync_3.0.7
+dnl 07/06/2010 - qhe
+
+dnl AC_VALIDATE_CACHE_SYSTEM_TYPE[(cmd)]
+dnl if the cache file is inconsistent with the current host,
+dnl target and build system types, execute CMD or print a default
+dnl error message.
+AC_DEFUN(AC_VALIDATE_CACHE_SYSTEM_TYPE, [
+    AC_REQUIRE([AC_CANONICAL_SYSTEM])
+    AC_MSG_CHECKING([config.cache system type])
+    if { test x"${ac_cv_host_system_type+set}" = x"set" &&
+         test x"$ac_cv_host_system_type" != x"$host"; } ||
+       { test x"${ac_cv_build_system_type+set}" = x"set" &&
+         test x"$ac_cv_build_system_type" != x"$build"; } ||
+       { test x"${ac_cv_target_system_type+set}" = x"set" &&
+         test x"$ac_cv_target_system_type" != x"$target"; }; then
+       AC_MSG_RESULT([different])
+       ifelse($#, 1, [$1],
+               [AC_MSG_ERROR(["you must remove config.cache and restart configure"])])
+    else
+       AC_MSG_RESULT([same])
+    fi
+    ac_cv_host_system_type="$host"
+    ac_cv_build_system_type="$build"
+    ac_cv_target_system_type="$target"
+])
+
+dnl Check for socklen_t: historically on BSD it is an int, and in
+dnl POSIX 1g it is a type of its own, but some platforms use different
+dnl types for the argument to getsockopt, getpeername, etc.  So we
+dnl have to test to find something that will work.
+
+dnl This is no good, because passing the wrong pointer on C compilers is
+dnl likely to only generate a warning, not an error.  We don't call this at
+dnl the moment.
+
+AC_DEFUN([TYPE_SOCKLEN_T],
+[
+   AC_CHECK_TYPE([socklen_t], ,[
+      AC_MSG_CHECKING([for socklen_t equivalent])
+      AC_CACHE_VAL([rsync_cv_socklen_t_equiv],
+      [
+         # Systems have either "struct sockaddr *" or
+         # "void *" as the second argument to getpeername
+         rsync_cv_socklen_t_equiv=
+         for arg2 in "struct sockaddr" void; do
+            for t in int size_t unsigned long "unsigned long"; do
+               AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/socket.h>
+
+                  int getpeername (int, $arg2 *, $t *);
+               ],[
+                  $t len;
+                  getpeername(0,0,&len);
+               ],[
+                  rsync_cv_socklen_t_equiv="$t"
+                  break
+               ])
+            done
+         done
+
+         if test "x$rsync_cv_socklen_t_equiv" = x; then
+            AC_MSG_ERROR([Cannot find a type to use in place of socklen_t])
+         fi
+      ])
+      AC_MSG_RESULT($rsync_cv_socklen_t_equiv)
+      AC_DEFINE_UNQUOTED(socklen_t, $rsync_cv_socklen_t_equiv,
+                       [type to use in place of socklen_t if not defined])],
+      [#include <sys/types.h>
+#include <sys/socket.h>])
+])
+
+dnl AC_HAVE_TYPE(TYPE,INCLUDES)
+AC_DEFUN([AC_HAVE_TYPE], [
+AC_REQUIRE([AC_HEADER_STDC])
+cv=`echo "$1" | sed 'y%./+- %__p__%'`
+AC_MSG_CHECKING(for $1)
+AC_CACHE_VAL([ac_cv_type_$cv],
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+AC_INCLUDES_DEFAULT
+$2]],
+[[$1 foo;]])],
+[eval "ac_cv_type_$cv=yes"],
+[eval "ac_cv_type_$cv=no"]))dnl
+ac_foo=`eval echo \\$ac_cv_type_$cv`
+AC_MSG_RESULT($ac_foo)
+if test "$ac_foo" = yes; then
+  ac_tr_hdr=HAVE_`echo $1 | sed 'y%abcdefghijklmnopqrstuvwxyz./- %ABCDEFGHIJKLMNOPQRSTUVWXYZ____%'`
+if false; then
+       AC_CHECK_TYPES($1)
+fi
+  AC_DEFINE_UNQUOTED($ac_tr_hdr, 1, [Define if you have type `$1'])
+fi
+])
diff --git a/meta/packages/rsync/rsync.inc b/meta/packages/rsync/rsync.inc
new file mode 100644 (file)
index 0000000..fdc7e37
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "A file-synchronization tool"
+HOMEPAGE = "http://rsync.samba.org/"
+BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
+SECTION = "console/network"
+PRIORITY = "optional"
+
+# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+# needs to add acl and attr
+DEPENDS = "popt"
+
+SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \
+           file://rsyncd.conf"
+
+inherit autotools
+
+do_install_append() {
+       install -d ${D}/etc
+       install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
+}
+
+EXTRA_OEMAKE='STRIP=""'
index 2b0275b292b5d215a912c62cec3b3ac8ccea20b0..a9b5c86d8feca691a3ff3a5d4523fe06fa9a4aea 100644 (file)
@@ -1,20 +1,6 @@
-DESCRIPTION = "A file-synchronization tool"
-HOMEPAGE = "http://rsync.samba.org/"
-BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
-SECTION = "console/network"
-PRIORITY = "optional"
+require rsync.inc
 
-# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
 LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c"
 
-SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \
-           file://rsyncd.conf"
-
-inherit autotools
-
-do_install_append() {
-       install -d ${D}/etc
-       install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
-}
-
-EXTRA_OEMAKE='STRIP=""'
+PR = "r1"
diff --git a/meta/packages/rsync/rsync_3.0.7.bb b/meta/packages/rsync/rsync_3.0.7.bb
new file mode 100644 (file)
index 0000000..61355d7
--- /dev/null
@@ -0,0 +1,16 @@
+require rsync.inc
+
+PR = "r0"
+
+SRC_URI += "file://acinclude.m4"
+
+# rsync 3.0 uses configure.sh instead of configure, and
+# makefile checks the existence of configure.sh
+do_configure_prepend () {
+       rm -f configure configure.sh
+       cp -f ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_configure_append () {
+       cp -f configure configure.sh
+}