]> code.ossystems Code Review - openembedded-core.git/commitdiff
lighttpd: Use PACKAGECONFIG to enable openssl
authorQian Lei <qianl.fnst@cn.fujitsu.com>
Thu, 22 Jan 2015 06:01:09 +0000 (14:01 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 28 Jan 2015 21:23:02 +0000 (21:23 +0000)
Enabled openssl defalutly to use https, just like ubuntu do.

Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb

index 20d5c1caa07116c73e89b15a57d42f98bac23e8e..0cf5aa2df230f0af5d53cc2be61810027ff1dfdf 100644 (file)
@@ -29,6 +29,9 @@ SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.t
 SRC_URI[md5sum] = "f7a88130ee9984b421ad8aa80629750a"
 SRC_URI[sha256sum] = "4a71c1f6d8af41ed894b507720c4c17184dc320590013881d5170ca7f15c5bf7"
 
+PACKAGECONFIG ??= "openssl"
+PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
+
 EXTRA_OECONF = " \
              --without-bzip2 \
              --without-ldap \
@@ -37,7 +40,6 @@ EXTRA_OECONF = " \
              --with-pcre \
              --without-webdav-props \
              --without-webdav-locks \
-             --without-openssl \
              --disable-static \
 "