]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: add python3 metapackage
authorRoss Burton <ross.burton@intel.com>
Mon, 24 Apr 2017 14:43:57 +0000 (15:43 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 May 2017 11:21:34 +0000 (12:21 +0100)
Many new users add "python3" to their image using IMAGE_INSTALL and are then
surprised that they can't import any of the standard library. This is because we
split up the standard library into a number of packages, and python3-core (the
interpreter and essential modules only) RPROVIDES 'python3'.

Solve this by moving the RPROVIDES of 'python3' to python3-modules, so that the
entire Python standard library is installed.

[ YOCTO #11182 ]

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python3_3.5.2.bb

index 2ff7c9e278076985e16610c43a48fbd461675bd0..7f2bc7186f5a1ef5a968db31065a72de787de1ed 100644 (file)
@@ -193,7 +193,7 @@ py_package_preprocess () {
 require python-${PYTHON_MAJMIN}-manifest.inc
 
 # manual dependency additions
-RPROVIDES_${PN}-core = "${PN}"
+RPROVIDES_${PN}-modules = "${PN}"
 RRECOMMENDS_${PN}-core = "${PN}-readline"
 RRECOMMENDS_${PN}-crypt = "openssl"
 RRECOMMENDS_${PN}-crypt_class-nativesdk = "nativesdk-openssl"