]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2/libxslt: Don't depend on ansidecl.h header
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 25 May 2012 09:15:39 +0000 (09:15 +0000)
committerScott Garman <scott.a.garman@intel.com>
Fri, 30 Nov 2012 22:50:15 +0000 (14:50 -0800)
We don't DEPEND on binutils for ansidecl.h so ensure we should never
use the header. This makes builds determinstic and means something like:

bitbake binutils
bitbake libxml2 -c configure
bitbake binutils -c clean
bitbake libxml2

doen't fail to build.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/libxml/libxml2.inc
meta/recipes-support/libxslt/libxslt_1.1.26.bb

index 2eecbd30e7ad68630ce5729a9c26b31c9d59f5d5..32d6e8cd31e8eb9c3251fd742041313941a65ef4 100644 (file)
@@ -18,6 +18,11 @@ SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
 
 inherit autotools pkgconfig binconfig
 
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+       sed -i -e '/.*ansidecl.h.*/d' ${S}/configure.in
+}
+
 EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
 EXTRA_OECONF_virtclass-native = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n"
 EXTRA_OECONF_virtclass-nativesdk = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n"
index 8986e207234702d7a2fe191e6e92154bcd3bcfb9..e4cc21472b86741542d83009582c875e2b6fdda6 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
 
 SECTION = "libs"
 DEPENDS = "libxml2"
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
            file://pkgconfig_fix.patch"
@@ -18,6 +18,11 @@ S = "${WORKDIR}/libxslt-${PV}"
 
 inherit autotools pkgconfig binconfig lib_package
 
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+       sed -i -e 's/ansidecl.h//' ${S}/configure.in
+}
+
 EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
 # older versions of this recipe had ${PN}-utils
 RPROVIDES_${PN}-bin += "${PN}-utils"