]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu-helper: Fix symlinks
authorRichard Purdie <richard@openedhand.com>
Mon, 11 Feb 2008 10:25:26 +0000 (10:25 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 11 Feb 2008 10:25:26 +0000 (10:25 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3738 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/qemu/qemu-helper-sdk_1.0.bb

index 4e3a15b762596861aaa72536285fa8906e525c63..49136c7dbf019e3a801315fc967516be70ee8366 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Qemu helper scripts from Poky"
 LICENSE = "GPL"
 RDEPENDS = "qemu-sdk"
-PR = "r5"
+PR = "r6"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-helper"
 
@@ -17,20 +17,18 @@ inherit sdk
 
 do_compile() {
        ${CC} raw2flash.c -o raw2flash.spitz
-       ln -fs raw2flash.spitz raw2flash.akita
-       ln -fs raw2flash.spitz raw2flash.borzoi
-       ln -fs raw2flash.spitz raw2flash.terrier
        ${CC} raw2flash.c -o flash2raw.spitz -Dflash2raw
-       ln -fs flash2raw.spitz flash2raw.akita
-       ln -fs flash2raw.spitz flash2raw.borzoi
-       ln -fs flash2raw.spitz flash2raw.terrier
 }
 
 do_install() {
        install -d ${D}${bindir}
        install -m 0755 poky-* ${D}${bindir}/
-       install -m 0755 *.akita ${D}${bindir}/
-       install -m 0755 *.spitz ${D}${bindir}/
-       install -m 0755 *.borzoi ${D}${bindir}/
-       install -m 0755 *.terrier ${D}${bindir}/
+       install raw2flash.spitz ${D}${bindir}/
+       install flash2raw.spitz ${D}${bindir}/
+       ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.akita
+       ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.borzoi
+       ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.terrier
+       ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.akita
+       ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.borzoi
+       ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.terrier
 }