]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcap: fix (base_)libdir usage
authorKoen Kooi <koen@dominion.thruhere.net>
Mon, 16 Apr 2018 13:00:19 +0000 (15:00 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 May 2018 09:00:10 +0000 (10:00 +0100)
The recipe wants to install libs into base_libdir, but uses "basename $libdir" to derive that. That breaks in a multiarch setup. Use the proper variable and remove the inline python usage.

Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/libcap/libcap_2.25.bb

index d619a2eb4cc91c5b0c9b51502d39395b610d7b64..47ecf345499391f7a920e5f997c5ad6b047d538c 100644 (file)
@@ -32,7 +32,7 @@ PACKAGECONFIG[pam] = "PAM_CAP=yes,PAM_CAP=no,libpam"
 
 EXTRA_OEMAKE = " \
   INDENT=  \
-  lib=${@os.path.basename('${libdir}')} \
+  lib='${base_libdir}' \
   RAISE_SETFCAP=no \
   DYNAMIC=yes \
   BUILD_GPERF=yes \