]> code.ossystems Code Review - openembedded-core.git/commitdiff
yum: Fix installation of python modules
authorJoshua Lock <josh@linux.intel.com>
Wed, 24 Mar 2010 17:29:02 +0000 (17:29 +0000)
committerJoshua Lock <josh@linux.intel.com>
Fri, 26 Mar 2010 10:29:18 +0000 (10:29 +0000)
Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/packages/yum/files/paths2.patch
meta/packages/yum/yum_3.2.27.bb

index 08c9c8312e74b736ac8a97763f937bd1628c76e8..8fe6d0c983a4638765cca2ac304ebb7604d2d836 100644 (file)
@@ -3,31 +3,33 @@
  yum/Makefile      |    2 +-
  2 files changed, 2 insertions(+), 2 deletions(-)
 
---- yum-3.2.18.orig/rpmUtils/Makefile
-+++ yum-3.2.18/rpmUtils/Makefile
-@@ -1,10 +1,10 @@
- PYTHON=python
+Index: yum-3.2.27/rpmUtils/Makefile
+===================================================================
+--- yum-3.2.27.orig/rpmUtils/Makefile  2010-03-24 17:26:39.759798777 +0000
++++ yum-3.2.27/rpmUtils/Makefile       2010-03-24 17:26:54.835863845 +0000
+@@ -2,8 +2,8 @@
  PACKAGE = $(shell basename `pwd`)
  PYFILES = $(wildcard *.py)
  PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
 -PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
-+PYSYSDIR = /usr
- PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+-PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
++PYSYSDIR = $(libdir)
++PYLIBDIR = $(PYSYSDIR)/python$(PYVER)
  PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
  
  all: 
-       echo "Nothing to do"
---- yum-3.2.18.orig/yum/Makefile
-+++ yum-3.2.18/yum/Makefile
-@@ -1,10 +1,10 @@
- PYTHON=python
+Index: yum-3.2.27/yum/Makefile
+===================================================================
+--- yum-3.2.27.orig/yum/Makefile       2010-03-24 17:26:39.759798777 +0000
++++ yum-3.2.27/yum/Makefile    2010-03-24 17:26:43.726773783 +0000
+@@ -2,8 +2,8 @@
  PACKAGE = $(shell basename `pwd`)
  PYFILES = $(wildcard *.py)
  PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
 -PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
-+PYSYSDIR = /usr
- PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+-PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
++PYSYSDIR = $(libdir)
++PYLIBDIR = $(PYSYSDIR)/python$(PYVER)
  PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
  
  all: 
-       echo "Nothing to do"
index e51aacd562914fd0424aca0fbe33a1baa95c95af..75669af448c42f5e9b782b66b662742e6a75c183 100644 (file)
@@ -1,5 +1,5 @@
 HOMEPAGE = "http://linux.duke.edu/projects/yum/"
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
            file://paths.patch;patch=1 \