]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpcbind: add patch to fix host include path
authorSaul Wold <Saul.Wold@intel.com>
Thu, 2 Sep 2010 18:52:24 +0000 (11:52 -0700)
committerSaul Wold <Saul.Wold@intel.com>
Thu, 2 Sep 2010 18:59:08 +0000 (11:59 -0700)
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
meta/recipes-extended/rpcbind/files/fix_host_path.patch [new file with mode: 0644]
meta/recipes-extended/rpcbind/rpcbind_0.2.0.bb

diff --git a/meta/recipes-extended/rpcbind/files/fix_host_path.patch b/meta/recipes-extended/rpcbind/files/fix_host_path.patch
new file mode 100644 (file)
index 0000000..1b12d83
--- /dev/null
@@ -0,0 +1,14 @@
+This fixes the hardcoded HOST path
+
+Signed-off-by: Saul Wold <saul.wold@intel.com>
+
+--- rpcbind-0.2.0/src/Makefile.am      2010-09-02 11:47:16.725763886 -0700
++++ rpcbind-0.2.0_fixed/src/Makefile.am        2010-09-02 11:47:36.077763138 -0700
+@@ -29,6 +29,6 @@
+ rpcbind_LDFLAGS = -lpthread -ltirpc
+ rpcbind_LDADD = $(LIB_TIRPC)
+-AM_CPPFLAGS = -I/usr/include/tirpc -DCHECK_LOCAL -DPORTMAP \
++AM_CPPFLAGS = -I=/usr/include/tirpc -DCHECK_LOCAL -DPORTMAP \
+                        -DFACILITY=LOG_MAIL -DSEVERITY=LOG_INFO
+
index 0894769a0eb0c4067509e0379c4725c11c57b931..a8c600665c7eda562ba17c3f86097a015032317a 100644 (file)
@@ -9,8 +9,10 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \
                     file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2"
+SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
+           file://fix_host_path.patch \
+          "
 
-PR = "r0"
+PR = "r1"
 
 inherit autotools