]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add udev 092
authorRichard Purdie <richard@openedhand.com>
Tue, 13 Jun 2006 13:56:15 +0000 (13:56 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 13 Jun 2006 13:56:15 +0000 (13:56 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@474 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/udev/udev-092/flags.patch [new file with mode: 0644]
openembedded/packages/udev/udev-092/init [new file with mode: 0644]
openembedded/packages/udev/udev-092/local.rules [new file with mode: 0644]
openembedded/packages/udev/udev-092/udev.rules [new file with mode: 0644]
openembedded/packages/udev/udev_092.bb [new file with mode: 0644]

diff --git a/openembedded/packages/udev/udev-092/flags.patch b/openembedded/packages/udev/udev-092/flags.patch
new file mode 100644 (file)
index 0000000..492a398
--- /dev/null
@@ -0,0 +1,51 @@
+--- udev-089/Makefile.orig     2006-04-08 13:32:53.000000000 +0200
++++ udev-089/Makefile  2006-04-08 13:34:27.000000000 +0200
+@@ -117,28 +117,28 @@
+ AR = $(CROSS_COMPILE)ar
+ RANLIB = $(CROSS_COMPILE)ranlib
+-CFLAGS                = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS               = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ WARNINGS      = -Wstrict-prototypes -Wsign-compare -Wshadow \
+                 -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
+                 -Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
+-CFLAGS                += $(WARNINGS)
++override CFLAGS               += $(WARNINGS)
+ LDFLAGS = -Wl,-warn-common
+ OPTFLAGS = -Os
+-CFLAGS += $(OPTFLAGS)
++override CFLAGS += $(OPTFLAGS)
+ ifeq ($(strip $(USE_LOG)),true)
+-      CFLAGS += -DUSE_LOG
++      override CFLAGS += -DUSE_LOG
+ endif
+ # if DEBUG is enabled, then we do not strip
+ ifeq ($(strip $(DEBUG)),true)
+-      CFLAGS  += -DDEBUG
++      override CFLAGS  += -DDEBUG
+ endif
+ ifeq ($(strip $(USE_GCOV)),true)
+-      CFLAGS += -fprofile-arcs -ftest-coverage
++      override CFLAGS += -fprofile-arcs -ftest-coverage
+       LDFLAGS += -fprofile-arcs
+ endif
+@@ -151,11 +151,11 @@
+ ifeq ($(strip $(USE_SELINUX)),true)
+       UDEV_OBJS += udev_selinux.o
+       LIB_OBJS += -lselinux -lsepol
+-      CFLAGS += -DUSE_SELINUX
++      override CFLAGS += -DUSE_SELINUX
+ endif
+ ifeq ($(strip $(USE_STATIC)),true)
+-      CFLAGS += -DUSE_STATIC
++      override CFLAGS += -DUSE_STATIC
+       LDFLAGS += -static
+ endif
diff --git a/openembedded/packages/udev/udev-092/init b/openembedded/packages/udev/udev-092/init
new file mode 100644 (file)
index 0000000..5a60d52
--- /dev/null
@@ -0,0 +1,227 @@
+#!/bin/sh -e
+### BEGIN INIT INFO
+# Provides:          udev
+# Required-Start:    mountvirtfs 
+# Required-Stop:     
+# Default-Start:     S
+# Default-Stop:
+# Short-Description: Start udevd, populate /dev and load drivers.
+### END INIT INFO
+
+# we need to unmount /dev/pts/ and remount it later over the tmpfs
+unmount_devpts() {
+  if mountpoint -q /dev/pts/; then
+    umount -l /dev/pts/
+  fi
+
+  if mountpoint -q /dev/shm/; then
+    umount -l /dev/shm/
+  fi
+}
+
+# mount a tmpfs over /dev, if somebody did not already do it
+mount_tmpfs() {
+  if grep -E -q "^[^[:space:]]+ /dev tmpfs" /proc/mounts; then
+    return
+  fi
+
+  # /dev/.static/dev/ is used by MAKEDEV to access the real /dev/ directory.
+  # /etc/udev/ is recycled as a temporary mount point because it's the only
+  # directory which is guaranteed to be available.
+  mount -n -o bind /dev /etc/udev
+
+  if ! mount -n -o size=$tmpfs_size,mode=0755 -t tmpfs tmpfs /dev; then
+    umount /etc/udev
+    echo "udev requires tmpfs support, not started."
+    exit 1
+  fi
+
+  mkdir -p /dev/.static/dev
+  chmod 700 /dev/.static/
+  # The mount options in busybox are non-standard...
+  if test -x /bin/mount.util-linux
+  then
+    /bin/mount.util-linux --move /etc/udev /dev/.static/dev
+  elif test -x /bin/busybox
+  then
+    busybox mount -n -o move /etc/udev /dev/.static/dev
+  else
+    echo "udev requires an identifiable mount command, not started."
+    umount /etc/udev
+    umount /dev
+    exit 1
+  fi
+}
+
+# I hate this hack.  -- Md
+make_extra_nodes() {
+  if [ "$(echo /lib/udev/devices/*)" != "/lib/udev/devices/*" ]; then
+    cp -a /lib/udev/devices/* /dev/
+  fi
+
+  [ -e /etc/udev/links.conf ] || return 0
+  grep '^[^#]' /etc/udev/links.conf | \
+  while read type name arg1; do
+    [ "$type" -a "$name" -a ! -e "/dev/$name" -a ! -L "/dev/$name" ] ||continue
+    case "$type" in
+      L) ln -s $arg1 /dev/$name ;;
+      D) mkdir -p /dev/$name ;;
+      M) mknod -m 600 /dev/$name $arg1 ;;
+      *) echo "links.conf: unparseable line ($type $name $arg1)" ;;
+    esac
+  done
+}
+
+supported_kernel() {
+  case "$(uname -r)" in
+    2.[012345].*|2.6.[0-9]|2.6.[0-9][!0-9]*) return 1 ;;
+    2.6.1[01]|2.6.1[01][!0-9]*) return 1 ;;
+  esac
+  return 0
+}
+
+set_hotplug_handler() {
+  case "$(uname -r)" in
+    2.6.1[0-4]|2.6.1[0-4][!0-9]*) HANDLER='/sbin/udevsend' ;;
+  esac
+  echo $HANDLER > /proc/sys/kernel/hotplug
+}
+
+# shell version of /usr/bin/tty
+my_tty() {
+  [ -x /bin/readlink ] || return 0
+  [ -e /proc/self/fd/0 ] || return 0
+  readlink --silent /proc/self/fd/0 || true
+}
+
+warn_if_interactive() {
+  if [ "$RUNLEVEL" = "S" -a "$PREVLEVEL" = "N" ]; then
+    return
+  fi
+
+  TTY=$(my_tty)
+  if [ -z "$TTY" -o "$TTY" = "/dev/console" ]; then
+    return
+  fi
+
+  printf "\n\n\nIt has been detected that the command\n\n\t$0 $*\n\n"
+  printf "has been run from an interactive shell.\n"
+  printf "It will probably not do what you expect, so this script will wait\n"
+  printf "60 seconds before continuing. Press ^C to stop it.\n"
+  printf "RUNNING THIS COMMAND IS HIGHLY DISCOURAGED!\n\n\n\n"
+  sleep 60
+}
+
+##############################################################################
+
+PATH="/sbin:/bin:/usr/bin"
+
+[ -x /sbin/udevd ] || exit 0
+
+# defaults
+tmpfs_size="10M"
+udev_root="/dev"
+udevd_timeout=30
+
+. /etc/udev/udev.conf
+
+if ! supported_kernel; then
+  echo "udev requires a kernel >= 2.6.12, not started."
+  exit 1
+fi
+
+if [ ! -e /proc/filesystems ]; then
+  echo "udev requires a mounted procfs, not started."
+  exit 1
+fi
+
+if ! grep -q '[[:space:]]tmpfs$' /proc/filesystems; then
+  echo "udev requires tmpfs support, not started."
+  exit 1
+fi
+
+if [ ! -d /sys/class/ ]; then
+  echo "udev requires a mounted sysfs, not started."
+  exit 1
+fi
+
+if [ ! -e /proc/sys/kernel/hotplug ]; then
+  echo "udev requires hotplug support, not started."
+  exit 1
+fi
+
+##############################################################################
+
+# When modifying this script, do not forget that between the time that
+# the new /dev has been mounted and udevsynthesize has been run there will be
+# no /dev/null. This also means that you cannot use the "&" shell command.
+
+case "$1" in
+    start)
+    if [ -e "$udev_root/.udev/" ]; then
+       if mountpoint -q /dev/; then
+           TMPFS_MOUNTED=1
+       else
+           echo ".udev/ already exists on the static $udev_root!"
+       fi
+    else
+       warn_if_interactive
+    fi
+
+    echo "Starting the hotplug events dispatcher" "udevd"
+    udevd --daemon
+
+    set_hotplug_handler
+
+    if [ -z "$TMPFS_MOUNTED" ]; then
+       unmount_devpts
+       mount_tmpfs
+       [ -d /proc/1 ] || mount -n /proc
+    fi
+
+    # if this directory is not present /dev will not be updated by udev
+    mkdir -p /dev/.udev/ /dev/.udev/db/ /dev/.udev/queue/ /dev/.udevdb/
+    # /dev/null must be created before udevd is started
+    make_extra_nodes
+
+    echo "Synthesizing the initial hotplug events"
+    udevsynthesize
+
+    # wait for the udevd childs to finish
+    echo "Waiting for /dev to be fully populated"
+    while [ -d /dev/.udev/queue/ ]; do
+       sleep 1
+       udevd_timeout=$(($udevd_timeout - 1))
+       if [ $udevd_timeout -eq 0 ]; then
+           # ps axf
+           break
+       fi
+    done
+    if [ $udevd_timeout -eq 0 ]; then
+       echo 'timeout'
+    fi
+    ;;
+
+    stop)
+    echo "Stopping the hotplug events dispatcher" "udevd"
+    start-stop-daemon --stop --name udevd --quiet
+    ;;
+
+    restart|force-reload)
+    echo "Stopping the hotplug events dispatcher" "udevd"
+    if start-stop-daemon --stop --name udevd --quiet ; then
+       exit 1
+    fi
+
+    echo "Starting the hotplug events dispatcher" "udevd"
+    udevd --daemon
+    ;;
+
+    *)
+    echo "Usage: /etc/init.d/udev {start|stop|restart|force-reload}"
+    exit 1
+    ;;
+esac
+
+exit 0
+
diff --git a/openembedded/packages/udev/udev-092/local.rules b/openembedded/packages/udev/udev-092/local.rules
new file mode 100644 (file)
index 0000000..445fea9
--- /dev/null
@@ -0,0 +1,31 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+#    For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Media automounting
+SUBSYSTEM=="block", ACTION=="add"    RUN+="/etc/udev/scripts/mount.sh"
+SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
+
+# Handle network interface setup
+SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
+SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
+
+# The first rtc device is symlinked to /dev/rtc
+KERNEL=="rtc0", SYMLINK+="rtc"
+
+# Try and modprobe for drivers for new hardware
+ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
+
+# Create a symlink to any touchscreen input device
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", SYSFS{modalias}=="input:*-e0,1*,3,*k*14A,*a0,1,*18,*", SYMLINK+="input/touchscreen"
\ No newline at end of file
diff --git a/openembedded/packages/udev/udev-092/udev.rules b/openembedded/packages/udev/udev-092/udev.rules
new file mode 100644 (file)
index 0000000..9c4ea42
--- /dev/null
@@ -0,0 +1,98 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+#    For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# SCSI devices
+BUS=="scsi", KERNEL=="sr[0-9]*",       NAME="scd%n", SYMLINK+="sr%n"
+
+# USB devices
+BUS=="usb", KERNEL=="auer[0-9]*",      NAME="usb/%k"
+BUS=="usb", KERNEL=="cpad[0-9]*",      NAME="usb/%k"
+BUS=="usb", KERNEL=="dabusb*",         NAME="usb/%k"
+BUS=="usb", KERNEL=="hiddev*",         NAME="usb/%k"
+BUS=="usb", KERNEL=="legousbtower*",   NAME="usb/%k"
+BUS=="usb", KERNEL=="lp[0-9]*",                NAME="usb/%k"
+BUS=="usb", KERNEL=="ttyUSB*", SYSFS{product}=="Palm Handheld*", \
+                                       SYMLINK+="pilot"
+
+# usbfs-like devices
+SUBSYSTEM=="usb_device", \
+       PROGRAM="/bin/sh -c 'export X=%k; export X=$${X#usbdev}; export B=$${X%%%%.*}; export D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c"
+
+# serial devices
+KERNEL=="capi",                        NAME="capi20", SYMLINK+="isdn/capi20"
+KERNEL=="capi[0-9]*",          NAME="capi/%n"
+
+# video devices
+KERNEL=="card[0-9]*",          NAME="dri/%k"
+
+# misc devices
+KERNEL=="hw_random",           NAME="hwrng"
+KERNEL=="tun",                 NAME="net/%k"
+
+KERNEL=="cdemu[0-9]*",         NAME="cdemu/%n"
+KERNEL=="pktcdvd[0-9]*",       NAME="pktcdvd/%n"
+KERNEL=="pktcdvd",             NAME="pktcdvd/control"
+
+KERNEL=="cpu[0-9]*",           NAME="cpu/%n/cpuid"
+KERNEL=="msr[0-9]*",           NAME="cpu/%n/msr"
+KERNEL=="microcode",           NAME="cpu/microcode"
+
+KERNEL=="umad*",               NAME="infiniband/%k"
+KERNEL=="issm*",               NAME="infiniband/%k"
+KERNEL=="uverbs*",             NAME="infiniband/%k"
+KERNEL=="ucm",                 NAME="infiniband/%k"
+
+KERNEL=="buzzer",              NAME="misc/buzzer"
+
+# ALSA devices
+KERNEL=="controlC[0-9]*",      NAME="snd/%k"
+KERNEL=="hwC[D0-9]*",          NAME="snd/%k"
+KERNEL=="pcmC[D0-9cp]*",       NAME="snd/%k"
+KERNEL=="midiC[D0-9]*",                NAME="snd/%k"
+KERNEL=="timer",               NAME="snd/%k"
+KERNEL=="seq",                 NAME="snd/%k"
+
+# ieee1394 devices       
+KERNEL=="dv1394*",             NAME="dv1394/%n"
+KERNEL=="video1394*",          NAME="video1394/%n"
+
+# input devices
+KERNEL=="mice",                        NAME="input/%k"
+KERNEL=="mouse[0-9]*",         NAME="input/%k"
+KERNEL=="event[0-9]*",         NAME="input/%k"
+KERNEL=="js[0-9]*",            NAME="input/%k"
+KERNEL=="ts[0-9]*",            NAME="input/%k"
+KERNEL=="uinput",              NAME="input/%k"
+
+# Zaptel
+KERNEL=="zapctl",              NAME="zap/ctl"
+KERNEL=="zaptimer",            NAME="zap/timer"
+KERNEL=="zapchannel",          NAME="zap/channel"
+KERNEL=="zappseudo",           NAME="zap/pseudo"
+KERNEL=="zap[0-9]*",           NAME="zap/%n"
+
+# AOE character devices
+SUBSYSTEM=="aoe", KERNEL=="discover",  NAME="etherd/%k"
+SUBSYSTEM=="aoe", KERNEL=="err",       NAME="etherd/%k"
+SUBSYSTEM=="aoe", KERNEL=="interfaces",        NAME="etherd/%k"
+
+# device mapper creates its own device nodes, so ignore these
+KERNEL=="dm-[0-9]*",           OPTIONS+="ignore_device"
+KERNEL=="device-mapper",       NAME="mapper/control"
+
+KERNEL=="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660"
+
+# Firmware Helper
+ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware_helper"
diff --git a/openembedded/packages/udev/udev_092.bb b/openembedded/packages/udev/udev_092.bb
new file mode 100644 (file)
index 0000000..62bc43d
--- /dev/null
@@ -0,0 +1,49 @@
+DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
+/dev/, handles hotplug events and loads drivers at boot time. It replaces \
+the hotplug package and requires a kernel not older than 2.6.12."
+RPROVIDES = "hotplug"
+
+PR = "r3"
+
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
+          file://noasmlinkage.patch;patch=1 \
+          file://flags.patch;patch=1 \
+          file://udevsynthesize.patch;patch=1 \
+          file://udevsynthesize.sh \
+          file://mount.blacklist"
+
+include udev.inc
+
+INITSCRIPT_PARAMS = "start 03 S ."
+
+FILES_${PN} += "${base_libdir}"
+UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/"
+EXTRA_OEMAKE += "libudevdir=/lib/udev"
+
+do_install () {
+       install -d ${D}${usrsbindir} \
+                  ${D}${sbindir}
+       oe_runmake 'DESTDIR=${D}' INSTALL=install install
+       install -d ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev
+
+       install -d ${D}${sysconfdir}/udev/rules.d/
+
+       install -m 0644 ${WORKDIR}/mount.blacklist     ${D}${sysconfdir}/udev/
+       install -m 0644 ${WORKDIR}/local.rules         ${D}${sysconfdir}/udev/rules.d/local.rules
+       install -m 0644 ${WORKDIR}/permissions.rules   ${D}${sysconfdir}/udev/rules.d/permissions.rules
+       install -m 0644 ${WORKDIR}/udev.rules          ${D}${sysconfdir}/udev/rules.d/udev.rules
+       install -m 0644 ${WORKDIR}/links.conf          ${D}${sysconfdir}/udev/links.conf
+       if [ "${UDEV_DEVFS_RULES}" = "1" ]; then
+               install -m 0644 ${WORKDIR}/devfs-udev.rules ${D}${sysconfdir}/udev/rules.d/devfs-udev.rules
+       fi
+
+       install -d ${D}${sysconfdir}/udev/scripts/
+
+       install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
+       install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
+
+       install -d ${D}${base_libdir}/udev/
+       install -m 0755 ${S}/udevsynthesize ${D}${base_libdir}/udev/udevsynthesize
+       install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize
+}