]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc: Clean up unnecessary variable confusion
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 25 Jan 2017 00:04:53 +0000 (00:04 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 26 Jan 2017 10:41:09 +0000 (10:41 +0000)
SDKPKGSUFFIX could only really be "nativesdk" and TARGET_SYS never contains
that so the code manipulating TARGET_SYS is pointless. I suspect this once
worked against MULTIMACH_TARGET_SYS which would be a different question but
it no longer does. Its been cut and pasted everywhere.

This patch cleans up the variable references to make things a little more
readable.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gcc/gcc-runtime.inc
meta/recipes-devtools/gcc/gcc-sanitizers.inc
meta/recipes-devtools/gcc/libgcc-common.inc
meta/recipes-devtools/gcc/libgfortran.inc

index 00856ad8bcf26b6c57b59250326f2173b80a1e36..745cf74f864683157d65192dd63a308f3f8b768d 100644 (file)
@@ -32,15 +32,14 @@ RUNTIMETARGET = "libssp libstdc++-v3 libgomp libatomic ${RUNTIMELIBITM} \
 
 do_configure () {
        export CXX="${CXX} -nostdinc++ -nostdlib++"
-       target=${TARGET_SYS}
 
        for d in libgcc ${RUNTIMETARGET}; do
                echo "Configuring $d"
-               rm -rf ${B}/$target/$d/
-               mkdir -p ${B}/$target/$d/
-               cd ${B}/$target/$d/
+               rm -rf ${B}/${TARGET_SYS}/$d/
+               mkdir -p ${B}/${TARGET_SYS}/$d/
+               cd ${B}/${TARGET_SYS}/$d/
                chmod a+x ${S}/$d/configure
-               relpath=${@os.path.relpath("${S}/$d", "${B}/$target/$d")}
+               relpath=${@os.path.relpath("${S}/$d", "${B}/${TARGET_SYS}/$d")}
                $relpath/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
        done
 }
@@ -48,18 +47,16 @@ EXTRACONFFUNCS += "extract_stashed_builddir"
 do_configure[depends] += "${COMPILERDEP}"
 
 do_compile () {
-       target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
        for d in libgcc ${RUNTIMETARGET}; do
-               cd ${B}/$target/$d/
-               oe_runmake MULTIBUILDTOP=${B}/$target/$d/
+               cd ${B}/${TARGET_SYS}/$d/
+               oe_runmake MULTIBUILDTOP=${B}/${TARGET_SYS}/$d/
        done
 }
 
 do_install () {
-       target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
        for d in ${RUNTIMETARGET}; do
-               cd ${B}/$target/$d/
-               oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/$d/ install
+               cd ${B}/${TARGET_SYS}/$d/
+               oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/${TARGET_SYS}/$d/ install
        done
        rm -rf ${D}${infodir}/libgomp.info ${D}${infodir}/dir
        rm -rf ${D}${infodir}/libitm.info ${D}${infodir}/dir
index ae3afe00b3d5c4d5ecebf4f287b75d01119fecf7..f97885b37250f2a57169bb22e343cb525a2a9e72 100644 (file)
@@ -12,34 +12,29 @@ EXTRA_OECONF_PATHS = "\
 "
 
 do_configure () {
-    target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
-
-    echo "Configuring libsanitizer"
-    rm -rf ${B}/$target/libsanitizer/
-    mkdir -p ${B}/$target/libsanitizer/
-    cd ${B}/$target/libsanitizer/
+    rm -rf ${B}/${TARGET_SYS}/libsanitizer/
+    mkdir -p ${B}/${TARGET_SYS}/libsanitizer/
+    cd ${B}/${TARGET_SYS}/libsanitizer/
     chmod a+x ${S}/libsanitizer/configure
-    relpath=${@os.path.relpath("${S}/libsanitizer", "${B}/$target/libsanitizer")}
+    relpath=${@os.path.relpath("${S}/libsanitizer", "${B}/${TARGET_SYS}/libsanitizer")}
     $relpath/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
     # Easiest way to stop bad RPATHs getting into the library since we have a
     # broken libtool here
-    sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${B}/$target/libsanitizer/libtool
+    sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${B}/${TARGET_SYS}/libsanitizer/libtool
     # Link to the sysroot's libstdc++ instead of one gcc thinks it just built
-    sed -i -e '/LIBSTDCXX_RAW_CXX_\(CXXFLAGS\|LDFLAGS\)\s*=/d' ${B}/$target/libsanitizer/*/Makefile
+    sed -i -e '/LIBSTDCXX_RAW_CXX_\(CXXFLAGS\|LDFLAGS\)\s*=/d' ${B}/${TARGET_SYS}/libsanitizer/*/Makefile
 }
 EXTRACONFFUNCS += "extract_stashed_builddir"
 do_configure[depends] += "${COMPILERDEP}"
 
 do_compile () {
-    target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
-    cd ${B}/$target/libsanitizer/
-    oe_runmake MULTIBUILDTOP=${B}/$target/libsanitizer/
+    cd ${B}/${TARGET_SYS}/libsanitizer/
+    oe_runmake MULTIBUILDTOP=${B}/${TARGET_SYS}/libsanitizer/
 }
 
 do_install () {
-    target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
-    cd ${B}/$target/libsanitizer/
-    oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/libsanitizer/ install
+    cd ${B}/${TARGET_SYS}/libsanitizer/
+    oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/${TARGET_SYS}/libsanitizer/ install
     if [ -d ${D}${infodir} ]; then
         rmdir --ignore-fail-on-non-empty -p ${D}${infodir}
     fi
index c0efc29437637f9f181c18bbc2d10e94a0469100..848a476207b19c50cbe146dc3b3533ccc904eed4 100644 (file)
@@ -5,10 +5,9 @@ require gcc-configure-common.inc
 INHIBIT_DEFAULT_DEPS = "1"
 
 do_configure () {
-       target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
        install -d ${D}${base_libdir} ${D}${libdir}
        mkdir -p ${B}/${BPN}
-       mkdir -p ${B}/$target/${BPN}/
+       mkdir -p ${B}/${TARGET_SYS}/${BPN}/
        cd ${B}/${BPN}
        chmod a+x ${S}/${BPN}/configure
        relpath=${@os.path.relpath("${S}/${BPN}", "${B}/${BPN}")}
@@ -18,15 +17,13 @@ EXTRACONFFUNCS += "extract_stashed_builddir"
 do_configure[depends] += "${COMPILERDEP}"
 
 do_compile () {
-       target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
        cd ${B}/${BPN}
-       oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/
+       oe_runmake MULTIBUILDTOP=${B}/${TARGET_SYS}/${BPN}/
 }
 
 do_install () {
-       target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
        cd ${B}/${BPN}
-       oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install
+       oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/${TARGET_SYS}/${BPN}/ install
 
        # Move libgcc_s into /lib
        mkdir -p ${D}${base_libdir}
index d3e2b411c808f67747463118105618f707f957bc..4846decbb8347de58f4e9799e1fac4b875fbcb07 100644 (file)
@@ -6,32 +6,27 @@ EXTRA_OECONF_PATHS = "\
 "
 
 do_configure () {
-       target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
-
-       echo "Configuring libgfortran"
-       rm -rf ${B}/$target/libgfortran/
-       mkdir -p ${B}/$target/libgfortran/
-       cd ${B}/$target/libgfortran/
+       rm -rf ${B}/${TARGET_SYS}/libgfortran/
+       mkdir -p ${B}/${TARGET_SYS}/libgfortran/
+       cd ${B}/${TARGET_SYS}/libgfortran/
        chmod a+x ${S}/libgfortran/configure
-       relpath=${@os.path.relpath("${S}/libgfortran", "${B}/$target/libgfortran")}
+       relpath=${@os.path.relpath("${S}/libgfortran", "${B}/${TARGET_SYS}/libgfortran")}
        $relpath/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
        # Easiest way to stop bad RPATHs getting into the library since we have a
        # broken libtool here
-       sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${B}/$target/libgfortran/libtool
+       sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${B}/${TARGET_SYS}/libgfortran/libtool
 }
 EXTRACONFFUNCS += "extract_stashed_builddir"
 do_configure[depends] += "${COMPILERDEP}"
 
 do_compile () {
-       target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
-       cd ${B}/$target/libgfortran/
-       oe_runmake MULTIBUILDTOP=${B}/$target/libgfortran/
+       cd ${B}/${TARGET_SYS}/libgfortran/
+       oe_runmake MULTIBUILDTOP=${B}/${TARGET_SYS}/libgfortran/
 }
 
 do_install () {
-       target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
-       cd ${B}/$target/libgfortran/
-       oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/libgfortran/ install
+       cd ${B}/${TARGET_SYS}/libgfortran/
+       oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/${TARGET_SYS}/libgfortran/ install
        if [ -d ${D}${libdir}/gcc/${TARGET_SYS}/${BINV}/finclude ]; then
                rmdir --ignore-fail-on-non-empty -p ${D}${libdir}/gcc/${TARGET_SYS}/${BINV}/finclude
        fi