]> code.ossystems Code Review - openembedded-core.git/commitdiff
ruby: make ext module fiddle can compile success
authorChangqing Li <changqing.li@windriver.com>
Thu, 11 Apr 2019 07:02:32 +0000 (15:02 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 11 Apr 2019 20:19:27 +0000 (21:19 +0100)
ext module fiddle depend on libffi, in ruby source tree,
there is in internal libffi in case target platfrom don't
install libffi, but autotools.bbclass delete configure
under libffi and not run autoreconf to regenerate one.so
we met this error:
ruby-2.5.3/ext/fiddle/libffi-3.2.1/configure: No such file or directory

the fix is add depend and extra_oeconf to use libffi in the system

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/ruby/ruby.inc
meta/recipes-devtools/ruby/ruby_2.5.3.bb

index eaf5d13ac2c789e817d60f4fb98439c54d81926f..28e21fee9cc0e53d0039ed57dfb4467356a8d2cc 100644 (file)
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "\
     file://LEGAL;md5=23a79bb4c1a40f6cc9bcb6f4e7c39799 \
 "
 
-DEPENDS = "ruby-native zlib openssl tcl libyaml gdbm readline"
+DEPENDS = "ruby-native zlib openssl tcl libyaml gdbm readline libffi"
 DEPENDS_class-native = "openssl-native libyaml-native readline-native"
 
 SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
index 3fb427e90ece005ac7577f47e79c8e526c8ff1c8..173b44b377e1e6c012fd1062820535fe55cced56 100644 (file)
@@ -28,6 +28,7 @@ EXTRA_OECONF = "\
     --disable-dtrace \
     --enable-shared \
     --enable-load-relative \
+    --with-pkg-config=pkg-config \
 "
 
 do_install() {