]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-dummy: provide empty shared_workdir method
authorKoen Kooi <koen.kooi@linaro.org>
Wed, 21 Jan 2015 09:07:35 +0000 (10:07 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 Jan 2015 10:37:53 +0000 (10:37 +0000)
Perf.bb (among others) requires access to the kernel source, so have linux-dummy fake that as well. As before, perf will fail to build, but there are use cases where this patch is needed. For example a perf.bbappend that will always build it from the debian linux-tools tarball.

Using linux-dummy is still a bad, bad idea, but it shouldn't start breaking existing use cases.

Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/linux/linux-dummy.bb

index 8f25f17e6f45cb2dfb324b30be1d2fae3153a2fd..cc0e4e64a9c13b0e9085fb33307153351516a966 100644 (file)
@@ -33,6 +33,10 @@ do_compile () {
        :
 }
 
+do_shared_workdir () {
+       :
+}
+
 do_install() {
        :
 }
@@ -47,4 +51,4 @@ do_deploy() {
 
 addtask bundle_initramfs after do_install before do_deploy
 addtask deploy after do_install
-
+addtask shared_workdir after do_compile before do_install