]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp: add patch from upstream to unbreak AArch64
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Tue, 8 Jan 2013 10:37:39 +0000 (11:37 +0100)
committerSaul Wold <sgw@linux.intel.com>
Thu, 10 Jan 2013 00:40:35 +0000 (16:40 -0800)
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/gmp/gmp-5.1.0/187b7b1646ee.patch [new file with mode: 0644]
meta/recipes-support/gmp/gmp_5.1.0.bb

diff --git a/meta/recipes-support/gmp/gmp-5.1.0/187b7b1646ee.patch b/meta/recipes-support/gmp/gmp-5.1.0/187b7b1646ee.patch
new file mode 100644 (file)
index 0000000..486f8c5
--- /dev/null
@@ -0,0 +1,44 @@
+Upstream-status: Backport
+
+# HG changeset patch
+# User Torbjorn Granlund <tege@gmplib.org>
+# Date 1357413121 -3600
+# Node ID 187b7b1646ee0ace782768bb36117b62c8408bb6
+# Parent  87a24013e9ee2cabf74e32282c18584a2c669009
+(aarch64): Make add_ssaaaa and sub_ddmmss actually work.
+
+diff -r 87a24013e9ee -r 187b7b1646ee longlong.h
+--- a/longlong.h       Fri Jan 04 16:32:01 2013 +0100
++++ b/longlong.h       Sat Jan 05 20:12:01 2013 +0100
+@@ -530,23 +530,16 @@
+ #endif /* __arm__ */
+ #if defined (__aarch64__) && W_TYPE_SIZE == 64
++/* FIXME: Extend the immediate range for the low word by using both
++   ADDS and SUBS, since they set carry in the same way.  */
+ #define add_ssaaaa(sh, sl, ah, al, bh, bl) \
+-  __asm__ ("adds\t%1, %4, %5\n\tadc\t%0, %2, %3"                      \
++  __asm__ ("adds\t%1, %x4, %5\n\tadc\t%0, %x2, %x3"                   \
+          : "=r" (sh), "=&r" (sl)                                      \
+-         : "r" (ah), "rZ" (bh), "%r" (al), "rI" (bl) __CLOBBER_CC)
++         : "rZ" (ah), "rZ" (bh), "%r" (al), "rI" (bl) __CLOBBER_CC)
+ #define sub_ddmmss(sh, sl, ah, al, bh, bl) \
+-  do {                                                                        \
+-    if (__builtin_constant_p (bl))                                    \
+-      {                                                                       \
+-      __asm__ ("subs\t%1, %4, %5\n\tsbc\t%0, %2, %3"                  \
+-               : "=r" (sh), "=&r" (sl)                                \
+-               : "r" (ah), "r" (bh), "r" (al), "rI" (bl) __CLOBBER_CC); \
+-      }                                                                       \
+-    else /* only bh might be a constant */                            \
+-      __asm__ ("subs\t%1, %4, %5\n\tsbc\t%0, %2, %3"                  \
+-             : "=r" (sh), "=&r" (sl)                                  \
+-             : "r" (ah), "rZ" (bh), "r" (al), "rI" (bl) __CLOBBER_CC);\
+-    } while (0)
++  __asm__ ("subs\t%1, %x4, %5\n\tsbc\t%0, %x2, %x3"                   \
++         : "=r,r" (sh), "=&r,&r" (sl)                                 \
++         : "rZ,rZ" (ah), "rZ,rZ" (bh), "r,Z" (al), "rI,r" (bl) __CLOBBER_CC)
+ #define umul_ppmm(ph, pl, m0, m1) \
+   do {                                                                        \
+     UDItype __m0 = (m0), __m1 = (m1);                                 \
+
index 9cb80fee46a2f3b3d3e115e104ce06a8a87b2454..eb5ef33ddfc8bf104f529521f99f76f8dcec17e4 100644 (file)
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
 
 SRC_URI_append = " file://use-includedir.patch \
                    file://gmp_fix_for_x32.patch \
+                   file://187b7b1646ee.patch \
                    "
 
 SRC_URI[md5sum] = "362cf515aff8dc240958ce47418e4c78"