]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: trim PGO patch
authorRoss Burton <ross.burton@intel.com>
Thu, 6 Sep 2018 11:15:19 +0000 (12:15 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Sep 2018 22:43:34 +0000 (23:43 +0100)
There's no need to delete the line that removes the profile data, as we're not
using it after the build.  This reduces the size of the patch, making it easier
to maintain.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3/0002-Makefile-add-target-to-split-profile-generation.patch

index bb01c5bcb46fcaff2e2e788927e53c0c10780c3e..2b4ba316e4544ee18771cf31b1d86cd3fb250f39 100644 (file)
@@ -19,7 +19,7 @@ diff --git a/Makefile.pre.in b/Makefile.pre.in
 index 84bc3ff..017a2c4 100644
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -469,13 +469,11 @@ profile-opt:
+@@ -469,13 +469,12 @@ profile-opt:
        $(MAKE) profile-removal
        $(MAKE) build_all_generate_profile
        $(MAKE) profile-removal
@@ -31,7 +31,7 @@ index 84bc3ff..017a2c4 100644
        @echo "Rebuilding with profile guided optimizations:"
        $(MAKE) clean
        $(MAKE) build_all_use_profile
--      $(MAKE) profile-removal
+       $(MAKE) profile-removal
  
  build_all_generate_profile:
        $(MAKE) @DEF_MAKE_RULE@ CFLAGS_NODIST="$(CFLAGS) $(EXTRA_CFLAGS) $(PGO_PROF_GEN_FLAG) @LTOFLAGS@" LDFLAGS="$(LDFLAGS) $(PGO_PROF_GEN_FLAG) @LTOFLAGS@" LIBS="$(LIBS)"