]> code.ossystems Code Review - openembedded-core.git/commitdiff
texi2html: update po_document/Makefile.in.in for new gettext
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 14 Jan 2015 06:38:07 +0000 (22:38 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 23 Jan 2015 11:35:24 +0000 (11:35 +0000)
* The autotools_do_configure updates po/Makefile.in.in, we also need
  update po_document and po_messages.

Fixed:
 *** error: gettext infrastructure mismatch:
using a Makefile.in.in from gettext version 0.18 but the autoconf macros are from gettext version 0.19

* Remove fix_gettext_version.patch, it wasn't a correct fix.

* Remove unneeded code from do_configure_append/prepend().

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-extended/texi2html/texi2html-5.0/fix_gettext_version.patch [deleted file]
meta/recipes-extended/texi2html/texi2html_5.0.bb

diff --git a/meta/recipes-extended/texi2html/texi2html-5.0/fix_gettext_version.patch b/meta/recipes-extended/texi2html/texi2html-5.0/fix_gettext_version.patch
deleted file mode 100644 (file)
index d1c9fe5..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
-
-Index: texi2html-5.0/po_document/Makefile.in.in
-===================================================================
---- texi2html-5.0.orig/po_document/Makefile.in.in
-+++ texi2html-5.0/po_document/Makefile.in.in
-@@ -9,7 +9,7 @@
- # General Public License and is *not* in the public domain.
- #
- # Origin: gettext-0.17
--GETTEXT_MACRO_VERSION = 0.17
-+GETTEXT_MACRO_VERSION = 0.18
- PACKAGE = @PACKAGE@
- VERSION = @VERSION@
-Index: texi2html-5.0/po_messages/Makefile.in.in
-===================================================================
---- texi2html-5.0.orig/po_messages/Makefile.in.in
-+++ texi2html-5.0/po_messages/Makefile.in.in
-@@ -9,7 +9,7 @@
- # General Public License and is *not* in the public domain.
- #
- # Origin: gettext-0.17
--GETTEXT_MACRO_VERSION = 0.17
-+GETTEXT_MACRO_VERSION = 0.18
- PACKAGE = @PACKAGE@
- VERSION = @VERSION@
index aa5f1fddaf0c4a32f639a7990456ac5c51f8e785..eac289e3b560831480b38e1595fb94a60fb6a4c0 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
 PR = "r2"
 
 SRC_URI     = "${SAVANNAH_GNU_MIRROR}/texi2html/${BPN}-${PV}.tar.bz2 \
-               file://fix_gettext_version.patch"
+               "
 
 SRC_URI[md5sum] = "f15ac876fcdc8be865b16535f480aa54"
 SRC_URI[sha256sum] = "e8a98b0ee20c495a6ab894398a065ef580272dbd5a15b1b19e8bd1bc89d9f9fa"
@@ -15,15 +15,10 @@ SRC_URI[sha256sum] = "e8a98b0ee20c495a6ab894398a065ef580272dbd5a15b1b19e8bd1bc89
 inherit autotools gettext texinfo
 
 do_configure_prepend() {
-       # Make a directory for the old gettext setup
-       if [ ! -d ${S}/po ]; then
-               mkdir ${S}/po
-       fi
-}
-
-do_configure_append() {
-       # Clean up the phony po directory
-       rm -rf ${S}/po
+       # autotools_do_configure updates po/Makefile.in.in, we also need
+       # update po_document.
+       cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_document/
+       cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po_messages/
 }
 
 do_install_append () {