]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Disable curl explicitly, its not in DEPENDS
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 Apr 2012 11:30:01 +0000 (11:30 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 Apr 2012 11:32:11 +0000 (12:32 +0100)
There is an error when build meta-toolchain-sdk on Ubuntu 10.10:

| Installing NATIVESDK packages
| Processing task-sdk-host-nativesdk...
| Processing task-cross-canadian-mips...
| error: Failed dependencies:
|       libcurl.so.4 is needed by qemu-nativesdk-0.15.1-r5.i686
NOTE: package meta-toolchain-gmae-1.0-r7: task do_populate_sdk: Failed
ERROR: Task 21 (/buildarea2/lyang1/poky/meta/recipes-core/meta/meta-toolchain-gmae.bb, do_populate_sdk) failed with exit code '1'

This is because qemu would depend on curl if it happened to be
available at build time and could confuse the -native and -nativesdk
librbaries.

[YOCTO #2305]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/qemu/qemu.inc

index 8dee0603383058aae68767a3d4fc0cedbd38cab2..93325c3bab27409280d2cee2e9eafd56b5e42829 100644 (file)
@@ -12,7 +12,7 @@ SDL ?= "--disable-sdl"
 SDL_virtclass-native ?= ""
 SDL_virtclass-nativesdk ?= ""
 
-EXTRA_OECONF += "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls --audio-drv-list=oss,alsa --audio-card-list=ac97,es1370 ${SDL}"
+EXTRA_OECONF += "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls --audio-drv-list=oss,alsa --audio-card-list=ac97,es1370 ${SDL} --disable-curl"
 
 #EXTRA_OECONF += "--disable-sdl"