]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: fix on-target use of distutils/setuptools by removing references to buildpaths
authorKoen Kooi <koen@dominion.thruhere.net>
Tue, 19 Mar 2013 09:09:38 +0000 (10:09 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 19 Mar 2013 11:51:00 +0000 (11:51 +0000)
Running 'python setup.py build' would fail due to the python Makefile having

CC=             i586-angstrom-linux-gcc  -m32    -march=core2 -msse3 -mtune=generic -mfpmath=sse --sysroot=/home/koen/v2012.12/build/tmp-angstrom_v2012_12-eglibc/sysroots/fri2
CXX=            i586-angstrom-linux-g++  -m32    -march=core2 -msse3 -mtune=generic -mfpmath=sse --sysroot=/home/koen/v2012.12/build/tmp-angstrom_v2012_12-eglibc/sysroots/fri2
'--with-libtool-sysroot=/home/koen/v2012.12/build/tmp-angstrom_v2012_12-eglibc/sysroots/fri2'

And more

Multiple users have reported this problem:

http://hipstercircuits.com/?p=499
http://www.gigamegablog.com/2012/09/09/beaglebone-coding-101-spi-output/

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python_2.7.3.bb

index c181933a6480700784642958ff44e4e65265bd50..aace95e729a25f2b6fb765603b977972ae2185c9 100644 (file)
@@ -122,6 +122,9 @@ PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
 py_package_preprocess () {
        # copy back the old Makefile to fix target package
        install -m 0644 Makefile.orig ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
+
+       # Remove references to buildmachine paths in target Makefile
+       sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
 }
 
 require python-${PYTHON_MAJMIN}-manifest.inc