]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/5.4: temporarily revert IKHEADERS in standard kernels
authorBruce Ashfield <bruce.ashfield@gmail.com>
Fri, 29 May 2020 01:29:17 +0000 (21:29 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 30 May 2020 11:31:48 +0000 (12:31 +0100)
We had a commit that enabled IKHEADERS, since bpf requires them on
target.

This is still causing incremental reproducibility errors during the
module compilation phase of the build.

We are temporarily turning this off, so we can integrate -stable
and other related changes. A replacement feature "reproducibility"
is also being added to this can be conditionally enabled while
we debug.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
meta/recipes-kernel/linux/linux-yocto_5.4.bb

index 760ded446af839dfef1ab61eadcdc39ae00b8054..e6366ee36d715016fcf6b80f5def319040129b86 100644 (file)
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "3d70f110c590b38219843a3a0815a232fd542cec"
-SRCREV_meta ?= "2647d22ea8ac2d3af6fe3b0d635cf84ee06f95e3"
+SRCREV_meta ?= "6d128007a79cdbecb66c5d8d186c0bbc41496526"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA}"
index 16459060347fa75c9c85e3690d5c2be7afd71de5..4a37c758b20f0673680c0ab93d40e6fcc47b51b0 100644 (file)
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine_qemuarm ?= "80606f0432a35225e7bff188a890b836018bae61"
 SRCREV_machine ?= "1ef0d05b4662a4e5a075db47e7e368e9a12c4877"
-SRCREV_meta ?= "2647d22ea8ac2d3af6fe3b0d635cf84ee06f95e3"
+SRCREV_meta ?= "6d128007a79cdbecb66c5d8d186c0bbc41496526"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index 068cebca2c17cab6e7b4a81c2741b40aa27c4aea..2bba72df77225918f4a5a070d9ba285a0ae7ede4 100644 (file)
@@ -21,7 +21,7 @@ SRCREV_machine_qemux86 ?= "1ef0d05b4662a4e5a075db47e7e368e9a12c4877"
 SRCREV_machine_qemux86-64 ?= "1ef0d05b4662a4e5a075db47e7e368e9a12c4877"
 SRCREV_machine_qemumips64 ?= "2da40cf3f065512eea3729172f8e3f0cf1857160"
 SRCREV_machine ?= "1ef0d05b4662a4e5a075db47e7e368e9a12c4877"
-SRCREV_meta ?= "2647d22ea8ac2d3af6fe3b0d635cf84ee06f95e3"
+SRCREV_meta ?= "6d128007a79cdbecb66c5d8d186c0bbc41496526"
 
 # remap qemuarm to qemuarma15 for the 5.4 kernel
 # KMACHINE_qemuarm ?= "qemuarma15"