]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: add missing some description in devtools
authorMaxime Roussin-Bélanger <maxime.roussinbelanger@gmail.com>
Wed, 2 Oct 2019 20:52:27 +0000 (16:52 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Oct 2019 22:12:31 +0000 (23:12 +0100)
Signed-off-by: Maxime Roussin-Bélanger <maxime.roussinbelanger@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/apt/apt.inc
meta/recipes-devtools/cmake/cmake.inc
meta/recipes-devtools/dejagnu/dejagnu_1.6.2.bb
meta/recipes-devtools/dnf/dnf_4.2.2.bb
meta/recipes-devtools/meson/meson.inc
meta/recipes-devtools/qemu/qemu.inc
meta/recipes-devtools/quilt/quilt.inc
meta/recipes-devtools/swig/swig.inc
meta/recipes-devtools/unfs3/unfs3_git.bb

index b855099e5280b014954d89ec97ca4bd833223f53..6883ac865a8045d4f837c2a39cd4e714a64f8fac 100644 (file)
@@ -1,4 +1,7 @@
 SUMMARY = "Advanced front-end for dpkg"
+DESCRIPTION = "Provides commandline tools for searching and managing as well \
+as querying information about packages as a low-level access to all features \
+of the libapt-pkg library."
 LICENSE = "GPLv2.0+"
 SECTION = "base"
 
index 3711f18db61d16ed24e6e13ffd677fb47de41b88..35d78eea1774f7e666cf92b773b835e586c3f6af 100644 (file)
@@ -2,6 +2,12 @@
 # Released under the MIT license (see packages/COPYING)
 
 SUMMARY = "Cross-platform, open-source make system"
+DESCRIPTION = "CMake is used to control the software compilation process \
+using simple platform and compiler independent configuration files. CMake \
+generates native makefiles and workspaces that can be used in the compiler \
+environment of your choice. CMake is quite sophisticated: it is possible to \
+support complex environments requiring system configuration, pre-processor \
+generation, code generation, and template instantiation."
 HOMEPAGE = "http://www.cmake.org/"
 BUGTRACKER = "http://public.kitware.com/Bug/my_view_page.php"
 SECTION = "console/utils"
index 7dc4e417f6eb311b0f66c3252db06eea3c891ac2..10220ebc917de1c829480f97faf80e8d3da4d215 100644 (file)
@@ -1,4 +1,6 @@
 SUMMARY = "GNU unit testing framework, written in Expect and Tcl"
+DESCRIPTION = "DejaGnu is a framework for testing other programs. Its purpose \
+is to provide a single front end for all tests."
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 SECTION = "devel"
index c77773332c176a58a364c8d770c9dd9eed85cfa1..f38167f1ad090f325d31ead95ac738861f5a19fd 100644 (file)
@@ -1,4 +1,7 @@
 SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
+DESCRIPTION = "Software package manager that installs, updates, and removes \
+packages on RPM-based Linux distributions. It automatically computes \
+dependencies and determines the actions required to install packages."
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                     file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \
@@ -71,7 +74,7 @@ do_install_append_class-native() {
 do_install_append_class-nativesdk() {
         create_wrapper ${D}/${bindir}/dnf \
                 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
-                RPM_NO_CHROOT_FOR_SCRIPTS=1 
+                RPM_NO_CHROOT_FOR_SCRIPTS=1
 }
 
 SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
index 6de109de7fd0d2bee19cf76e5dfe91a5a5555ca7..2958a2a8de4a719e02f6f4691ad02e21454cc1b2 100644 (file)
@@ -1,5 +1,8 @@
 HOMEPAGE = "http://mesonbuild.com"
 SUMMARY = "A high performance build system"
+DESCRIPTION = "Meson is a build system designed to increase programmer \
+productivity. It does this by providing a fast, simple and easy to use \
+interface for modern software development tools and practices."
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
index 551b49ac0a041dc2fd7199efeb89d10298d3f162..88ae68a1e9490ec03671cb68a0fc7eea3344bdfd 100644 (file)
@@ -1,4 +1,8 @@
 SUMMARY = "Fast open source processor emulator"
+DESCRIPTION = "QEMU is a hosted virtual machine monitor: it emulates the \
+machine's processor through dynamic binary translation and provides a set \
+of different hardware and device models for the machine, enabling it to run \
+a variety of guest operating systems"
 HOMEPAGE = "http://qemu.org"
 LICENSE = "GPLv2 & LGPLv2.1"
 
index 433e9b40b70b2682e6eee58e789ba02587d6e319..61e1c93605c026a9a7fe65fbb4366feccbc3e8f1 100644 (file)
@@ -1,4 +1,8 @@
 SUMMARY = "Tool for working with series of patches"
+DESCRIPTION = "Quilt is a tool to manage large sets of patches by keeping \
+track of the changes each patch makes. Patches can be applied, un-applied,\
+refreshed, etc. The key philosophical concept is that your primary output \
+is patches."
 HOMEPAGE = "http://savannah.nongnu.org/projects/quilt/"
 SECTION = "devel"
 LICENSE = "GPLv2"
index 00b9c5b605c5680a1b754d2cccad5756871e3901..e62718c508cadf58ccab634e49d5525a1e55ae6a 100644 (file)
@@ -1,4 +1,7 @@
 SUMMARY = "SWIG - Simplified Wrapper and Interface Generator"
+DESCRIPTION = "SWIG is a compiler that makes it easy to integrate C and C++ \
+code with other languages including Perl, Tcl, Ruby, Python, Java, Guile, \
+Mzscheme, Chicken, OCaml, Pike, and C#."
 HOMEPAGE = "http://swig.sourceforge.net/"
 LICENSE = "BSD & GPLv3"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e7807a6282784a7dde4c846626b08fc6 \
index a4ac46c68e50674916d6d2cf314a021b868d43bf..79d09788d3a4e67507765fccda2dfffde3496552 100644 (file)
@@ -1,4 +1,7 @@
 SUMMARY = "Userspace NFS server v3 protocol"
+DESCRIPTION = "UNFS3 is a user-space implementation of the NFSv3 server \
+specification. It provides a daemon for the MOUNT and NFS protocols, which \
+are used by NFS clients for accessing files on the server."
 SECTION = "console/network"
 LICENSE = "unfs3"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"