]> code.ossystems Code Review - openembedded-core.git/commitdiff
gzip: upgrade to 1.5
authorScott Garman <scott.a.garman@intel.com>
Fri, 22 Jun 2012 00:27:32 +0000 (17:27 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 25 Jun 2012 15:32:15 +0000 (16:32 +0100)
LIC_FILES_CHKSUM updated due to trivial copyright date change.

Use new update-alternatives syntax.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-extended/gzip/gzip.inc
meta/recipes-extended/gzip/gzip_1.4.bb [deleted file]
meta/recipes-extended/gzip/gzip_1.5.bb [new file with mode: 0644]

index 1d608a67137da03745b39075395e81edc61df62c..a4b1abe16580d82cf31be2a59cad1daa7718e470 100644 (file)
@@ -6,7 +6,7 @@ SECTION = "console/utils"
 # change to GPLv3+ in 2007/07. Previous GPLv2 version is 1.3.12
 LICENSE = "GPLv3+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
-                    file://gzip.h;firstline=8;endline=20;md5=e2ec6b91fbe43a18f6081f3bbae46a01"
+                    file://gzip.h;firstline=8;endline=20;md5=d31380638987e6789f06bc96a29a9a16"
 
 SRC_URI = "${GNU_MIRROR}/gzip/${BP}.tar.gz"
 
@@ -22,5 +22,8 @@ do_install_append () {
 
 inherit update-alternatives
 
-ALTERNATIVE_LINKS = "${base_bindir}/gunzip ${base_bindir}/gzip ${base_bindir}/zcat"
 ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "gunzip gzip zcat"
+ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
+ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
+ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
diff --git a/meta/recipes-extended/gzip/gzip_1.4.bb b/meta/recipes-extended/gzip/gzip_1.4.bb
deleted file mode 100644 (file)
index 54dd50a..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-require gzip.inc
-
-PR = "r2"
-
-NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
-
-BBCLASSEXTEND = "native"
-
-SRC_URI[md5sum] = "e381b8506210c794278f5527cba0e765"
-SRC_URI[sha256sum] = "d166cfd3da380da1bd535633e8890bfb5664f9e68870a611d1dc01a3e9f711ee"
diff --git a/meta/recipes-extended/gzip/gzip_1.5.bb b/meta/recipes-extended/gzip/gzip_1.5.bb
new file mode 100644 (file)
index 0000000..7a811e2
--- /dev/null
@@ -0,0 +1,10 @@
+require gzip.inc
+
+PR = "r0"
+
+NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
+
+BBCLASSEXTEND = "native"
+
+SRC_URI[md5sum] = "11b76536941ee1c0221fe6eefbcb32cb"
+SRC_URI[sha256sum] = "b5d56e8ffc9918e8c941fab56e04121194f9870adeeb859e09c09eac264035a3"