]> code.ossystems Code Review - openembedded-core.git/commitdiff
- Bump PR in matchbox-wm
authorChris Lord <chris@openedhand.com>
Tue, 27 Sep 2005 17:18:54 +0000 (17:18 +0000)
committerChris Lord <chris@openedhand.com>
Tue, 27 Sep 2005 17:18:54 +0000 (17:18 +0000)
- Define X_LIBS in libxsettings-client and startup-notification to stop them
  adding system dirs to the library path
- Add do_stage to matchbox-desktop

git-svn-id: https://svn.o-hand.com/repos/poky@44 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/libxsettings-client/libxsettings-client_0.14.bb
openembedded/packages/matchbox-desktop/matchbox-desktop_svn.bb
openembedded/packages/matchbox-wm/matchbox-wm_svn.bb
openembedded/packages/startup-notification/startup-notification_0.8.bb

index 11d0d3497b139775870bf72a22bcce531adf7aa4..1ccb6e4eb6e3d2dcb963e36ee831df3448b4dfaf 100644 (file)
@@ -2,12 +2,16 @@ SECTION = "gpe/libs"
 LICENSE = "BSD-X"
 PRIORITY = "optional"
 DEPENDS = "libxsettings x11"
+PR = "r1"
 
 inherit autotools pkgconfig gpe
 
 SRC_URI = "${GPE_MIRROR}/xsettings-client-${PV}.tar.bz2"
 S = ${WORKDIR}/xsettings-client-${PV}
 
+do_configure () {
+       X_LIBS=" -L${STAGING_LIBDIR}" oe_runconf
+}
 
 headers = "xsettings-client.h xsettings-common.h"
 do_stage () {
index ca193d42c19d8f16f67224d8213636a7f1eb67db..468caff25d0cdfc935d44b4d282e582b0e230a76 100644 (file)
@@ -23,3 +23,9 @@ FILES_${PN} = "${bindir} \
 FILES_${PN}-dev = "${libdir}/matchbox-desktop \
                   ${includedir}/matchbox-desktop \
                   ${datadir}/matchbox/desktop/modules/*a"
+
+do_stage() {
+       install -d ${STAGING_INCDIR}/matchbox-desktop/
+       install -m 0644 ${S}/src/*.h ${STAGING_INCDIR}/matchbox-desktop/
+}
+
index 48d9044f3b694728517eb7f880a2bb6861e53f22..f9765df44669ac4a254603c47653e07fcafaade4 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "GPL"
 DEPENDS = "libmatchbox x11 xext libxrender startup-notification expat matchbox-common gconf"
 RDEPENDS = "matchbox-common"
 PV = "0.9.5cvs${CVSDATE}"
-PR = "r3"
+PR = "r4"
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
index c4cc57440e1052ccddcf8b705302d74af6e055d7..a505a53960c22ed918725019d96bf82474cec81b 100644 (file)
@@ -4,11 +4,16 @@ SECTION = "libs"
 PRIORITY = "optional"
 MAINTAINER = "Phil Blundell <pb@nexus.co.uk>"
 DEPENDS = "x11"
+PR = "r1"
 
 inherit autotools pkgconfig 
 
 SRC_URI = "http://www.freedesktop.org/software/startup-notification/releases/startup-notification-0.8.tar.gz"
 
+do_configure_prepend () {
+        export X_LIBS=" -L${STAGING_LIBDIR}"
+}
+
 do_stage () {
        oe_runmake install DESTDIR="" bindir=${STAGING_BINDIR} includedir=${STAGING_INCDIR} libdir=${STAGING_LIBDIR} prefix=${STAGING_DIR}
 }