]> code.ossystems Code Review - openembedded-core.git/commitdiff
libuser: enable python support
authorKang Kai <kai.kang@windriver.com>
Mon, 10 Dec 2012 09:37:15 +0000 (17:37 +0800)
committerSaul Wold <sgw@linux.intel.com>
Wed, 12 Dec 2012 04:27:26 +0000 (20:27 -0800)
Compile libuser with python support and add python to DEPENDS.

Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/libuser/libuser_0.57.1.bb

index 99b661b978075efcb9c5500b8bca099974ba60e0..105bacfdd2203701cfcb4dca8ea54082c7ff8707 100644 (file)
@@ -15,10 +15,16 @@ SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz"
 
 SRC_URI[md5sum] = "be82c6941264d0b4bd04f95fb342ec7d"
 SRC_URI[sha256sum] = "a61289867581fa715354a3fafe09c3e481173ce0a2dcb33b04588b6ac13cead5"
-PR = "r2"
+PR = "r3"
 
-DEPENDS = "popt libpam glib-2.0 xz-native docbook-utils-native linuxdoc-tools-native"
+DEPENDS = "popt libpam glib-2.0 xz-native docbook-utils-native linuxdoc-tools-native python"
 
-EXTRA_OECONF += "--without-python"
+inherit autotools gettext pythonnative python-dir
+
+EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}"
+
+PACKAGES += "${PN}-python "
+
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
 
-inherit autotools gettext