]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-minimal-initramfs: force IMAGE_FSTYPES
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Fri, 4 Nov 2011 11:54:43 +0000 (11:54 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Nov 2011 14:03:38 +0000 (14:03 +0000)
If the user has set their own value for IMAGE_FSTYPES, they may have
disabled the cpio.gz image type, preventing the initramfs from being
produced in the format that image-live.bbclass expects; so force
IMAGE_FSTYPES to cpio.gz within the initramfs image recipe.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Prepend cpio.gz instead

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/images/core-image-minimal-initramfs.bb

index 0bac27a563d2a633ab16b13bdb1baec535a80b78..d078c1004f4ed93b104cca03b4eb40be24d3e2e8 100644 (file)
@@ -13,3 +13,4 @@ LICENSE = "MIT"
 inherit core-image
 
 IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_FSTYPES =+ "cpio.gz"