]> code.ossystems Code Review - openembedded-core.git/commitdiff
libsdl2: Add directfb to PACKAGECONFIG rdepends
authorMark Jonas <toertel@gmail.com>
Tue, 24 Nov 2020 19:32:50 +0000 (20:32 +0100)
committerSteve Sakoman <steve@sakoman.com>
Thu, 10 Dec 2020 14:11:06 +0000 (04:11 -1000)
PACKAGECONFIG[directfb] already adds directfb to the build
dependencies. But the automatically generated runtime
dependencies do not add the directfb package to the runtime
dependencies. Most likely this happens because libsdl2 does not link
against directfb but uses dlopen() or similar. Thus, the runtime
dependency to directfb needs to be declared explicitly.

Signed-off-by: Mark Jonas <toertel@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 62d3cbe7c8261c1c875ff6da11572409262aaf02)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-graphics/libsdl2/libsdl2_2.0.12.bb

index 1049aa548aa18387c8aeefef5af1e55d2370876f..fa7acc4c50f351362fe26785179e1b82e9e77345 100644 (file)
@@ -57,7 +57,7 @@ PACKAGECONFIG ??= " \
 "
 PACKAGECONFIG[alsa]       = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"
 PACKAGECONFIG[arm-neon]   = "--enable-arm-neon,--disable-arm-neon"
-PACKAGECONFIG[directfb]   = "--enable-video-directfb,--disable-video-directfb,directfb"
+PACKAGECONFIG[directfb]   = "--enable-video-directfb,--disable-video-directfb,directfb,directfb"
 PACKAGECONFIG[gles2]      = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2"
 PACKAGECONFIG[jack]       = "--enable-jack,--disable-jack,jack"
 PACKAGECONFIG[kmsdrm]     = "--enable-video-kmsdrm,--disable-video-kmsdrm,libdrm virtual/libgbm"