]> code.ossystems Code Review - openembedded-core.git/commitdiff
rsync: backport libattr checking patch
authorSergiy Kibrik <sakib@meta.ua>
Thu, 17 Sep 2015 13:08:02 +0000 (16:08 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 30 Jan 2016 12:01:43 +0000 (12:01 +0000)
Add check_libattr.patch to version 3.1.0 recipe, which checks
and includes libattr to linker, otherwise rsync may fail to build
with linker error below (as -lattr option gets omitted):

[..]
lib/sysxattrs.o: undefined reference to symbol 'llistxattr@@ATTR_1.0'
[..]/lib/libattr.so.1: error adding symbols: DSO missing from command line

Signed-off-by: Sergiy Kibrik <sakib@meta.ua>
Signed-off-by: Armin Kuster <akuster@mvista.com>
meta/recipes-devtools/rsync/files/check_libattr.patch [new file with mode: 0644]
meta/recipes-devtools/rsync/rsync_3.1.0.bb

diff --git a/meta/recipes-devtools/rsync/files/check_libattr.patch b/meta/recipes-devtools/rsync/files/check_libattr.patch
new file mode 100644 (file)
index 0000000..cb159fa
--- /dev/null
@@ -0,0 +1,33 @@
+From 677c6e14cc7d5f41371d5616865a5f0cfc0a273f Mon Sep 17 00:00:00 2001
+From: Wayne Davison <wayned@samba.org>
+Date: Mon, 5 May 2014 09:25:13 -0700
+Subject: [PATCH] Check for attr lib.
+
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c7b28c5..8e3703c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1007,7 +1007,7 @@ else
+     *)
+       AC_MSG_RESULT(running tests:)
+       AC_CHECK_LIB(acl,acl_get_file)
+-          AC_CACHE_CHECK([for ACL support],samba_cv_HAVE_POSIX_ACLS,[
++      AC_CACHE_CHECK([for ACL support],samba_cv_HAVE_POSIX_ACLS,[
+           AC_TRY_LINK([#include <sys/types.h>
+ #include <sys/acl.h>],
+ [ acl_t acl; int entry_id; acl_entry_t *entry_p; return acl_get_entry( acl, entry_id, entry_p);],
+@@ -1057,6 +1057,7 @@ else
+       AC_DEFINE(HAVE_LINUX_XATTRS, 1, [True if you have Linux xattrs])
+       AC_DEFINE(SUPPORT_XATTRS, 1)
+       AC_DEFINE(NO_SYMLINK_USER_XATTRS, 1, [True if symlinks do not support user xattrs])
++      AC_CHECK_LIB(attr,getxattr)
+       ;;
+     darwin*)
+       AC_MSG_RESULT(Using OS X xattrs)
+-- 
+1.9.1
+
index a4a5c102d46604074614ddb481cc8d9463ce8854..d253fe9bd6c46e369ed62586fa52d94040f455ee 100644 (file)
@@ -1,7 +1,8 @@
 require rsync.inc
 
 
-SRC_URI += "file://acinclude.m4"
+SRC_URI += "file://acinclude.m4 \
+           file://check_libattr.patch"
 
 SRC_URI[md5sum] = "3be148772a33224771a8d4d2a028b132"
 SRC_URI[sha256sum] = "81ca23f77fc9b957eb9845a6024f41af0ff0c619b7f38576887c63fa38e2394e"