]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: Ensure license is handled correctly
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Apr 2013 14:27:08 +0000 (14:27 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Apr 2013 14:31:21 +0000 (15:31 +0100)
The do_populate_lic task has a race with the recipe since it relies on the
kernel being populated in the sysroot. This patch adds in the explicit missing
dependency.

[YOCTO #3534]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 210c4cbf65fddce4fdf16b4019dd10c61b999d17..844e8807caa71d123ad28abe43e11ed9008d09a9 100644 (file)
@@ -41,6 +41,8 @@ export STAGING_LIBDIR
 export BUILD_SYS
 export HOST_SYS
 
+do_populate_lic[depends] += "virtual/kernel:do_populate_sysroot"
+
 # needed for building the tools/perf Perl binding
 inherit perlnative cpan-base
 # Env var which tells perl if it should use host (no) or target (yes) settings