]> code.ossystems Code Review - openembedded-core.git/commitdiff
clutter: Fix locked down revision patch
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 10 Dec 2009 16:59:56 +0000 (16:59 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 10 Dec 2009 16:59:56 +0000 (16:59 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch [new file with mode: 0644]
meta/packages/clutter/clutter_git.bb

diff --git a/meta/packages/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch b/meta/packages/clutter/clutter/enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch
new file mode 100644 (file)
index 0000000..953edf6
--- /dev/null
@@ -0,0 +1,32 @@
+---
+ tests/Makefile.am   |    7 ++++++-
+ tests/test-actors.c |    2 +-
+ tests/test-text.c   |    2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: git/tests/interactive/Makefile.am
+===================================================================
+--- git.orig/tests/interactive/Makefile.am     2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/Makefile.am  2009-03-12 11:04:12.000000000 +0000
+@@ -77,7 +77,7 @@
+ AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
+ AM_LDFLAGS = $(CLUTTER_LIBS)
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
+ test_interactive_SOURCES = \
+       test-main.c \
+Index: git/tests/interactive/test-actors.c
+===================================================================
+--- git.orig/tests/interactive/test-actors.c   2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/test-actors.c        2009-03-12 11:06:32.000000000 +0000
+@@ -182,7 +182,7 @@
+   oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
+   oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
+-  real_hand = clutter_texture_new_from_file ("redhand.png", &error);
++  real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error);
+   if (real_hand == NULL)
+     {
+       g_error ("image load failed: %s", error->message);
index 9432615e281d8be668a9db28c4af8252777afe22..b27fc11ccc5168840b4a3d98ff809027dcf6b61b 100644 (file)
@@ -2,10 +2,11 @@ require clutter.inc
 require clutter-package.inc
 
 PV = "1.0.0+git${SRCPV}"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "git://git.clutter-project.org/clutter.git;protocol=git;branch=master \
-           file://enable_tests.patch;patch=1 "
+           file://enable_tests-654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673.patch;patch=1;rev=654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673 \
+           file://enable_tests.patch;patch=1;notrev=654c26a1301c9bc5f8e3e5e3b68af5eb1b2e0673 "
 S = "${WORKDIR}/git"
 
 BASE_CONF += "--disable-introspection"