]> code.ossystems Code Review - openembedded-core.git/commitdiff
js: Fix mips build and other architecture inconsistency
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 10 Jun 2010 21:12:55 +0000 (22:12 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 10 Jun 2010 21:12:55 +0000 (22:12 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/js/files/usepic.patch [new file with mode: 0644]
meta/packages/js/js_1.5.bb

diff --git a/meta/packages/js/files/usepic.patch b/meta/packages/js/files/usepic.patch
new file mode 100644 (file)
index 0000000..ddd31be
--- /dev/null
@@ -0,0 +1,24 @@
+Mips needs -fPIC to compile properly. These tests are broken anyway as they test 
+the build system architecture, not the target. This is a hack.
+
+RP 10/6/2010
+
+Index: src/config/Linux_All.mk
+===================================================================
+--- src.orig/config/Linux_All.mk       2010-06-10 22:09:43.000000000 +0100
++++ src/config/Linux_All.mk    2010-06-10 22:09:55.000000000 +0100
+@@ -90,14 +90,10 @@
+ # Use the editline library to provide line-editing support.
+ JS_EDITLINE = 1
+-ifeq ($(CPU_ARCH),x86_64)
+ # Use VA_COPY() standard macro on x86-64
+ # FIXME: better use it everywhere
+ OS_CFLAGS += -DHAVE_VA_COPY -DVA_COPY=va_copy
+-endif
+-ifeq ($(CPU_ARCH),x86_64)
+ # We need PIC code for shared libraries
+ # FIXME: better patch rules.mk & fdlibm/Makefile*
+ OS_CFLAGS += -DPIC -fPIC
+-endif
index 1249268a4ff25d1e3ba1c8856a5610b8761c4c13..ce763338d33993fdb57fc5243dcba0bb98908073 100644 (file)
@@ -4,7 +4,9 @@ SECTION = "libs"
 DEPENDS = "readline"
 SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/js/older-packages/js-1.5.tar.gz \
            file://link_with_gcc.patch;patch=1 \
-          file://jsautocfg.h"
+           file://usepic.patch;patch=1 \
+           file://jsautocfg.h"
+PR = "r1"
 
 S = "${WORKDIR}/js/src"