]> code.ossystems Code Review - openembedded-core.git/commitdiff
pango: respect PTEST_ENABLED
authorRoss Burton <ross.burton@intel.com>
Wed, 3 Oct 2018 12:29:15 +0000 (13:29 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Oct 2018 15:31:50 +0000 (16:31 +0100)
Don't use the 'ptest' DISTRO_FEATURE because whilst that can be on,
PTEST_ENABLED could have been overwritten.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/pango/pango_1.42.4.bb

index fc610a9a5f9e21a7d21595a766b02443fad886d3..22fe3af15d742879ec2c2db3c273b5c7336f070e 100644 (file)
@@ -29,7 +29,7 @@ LIBV = "1.8.0"
 
 # This binary needs to be compiled for the host architecture.  This isn't pretty!
 do_compile_prepend_class-target () {
-       if ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
+       if ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
                make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="${BUILD_LDFLAGS}" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
        fi
 }