]> code.ossystems Code Review - openembedded-core.git/commitdiff
- Use gtk 2.6.7 as opposed to 2.8.3
authorChris Lord <chris@openedhand.com>
Fri, 23 Sep 2005 16:03:33 +0000 (16:03 +0000)
committerChris Lord <chris@openedhand.com>
Fri, 23 Sep 2005 16:03:33 +0000 (16:03 +0000)
- Use dbus 0.50 as opposed to 0.36
- Use svn versions of matchbox apps
- Update matchbox svn packages
- Add matchbox-common svn package
- Build gtk tools with gconf

git-svn-id: https://svn.o-hand.com/repos/poky@33 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/conf/distro/poky-additions.inc
openembedded/packages/gnome/gconf_2.6.1.bb
openembedded/packages/libmatchbox/libmatchbox_svn.bb
openembedded/packages/matchbox-common/matchbox-common_svn.bb [new file with mode: 0644]
openembedded/packages/matchbox-desktop/matchbox-desktop_svn.bb
openembedded/packages/matchbox-panel/matchbox-panel_svn.bb
openembedded/packages/matchbox-wm/matchbox-wm_svn.bb

index c72d959d0cb36233ab88c6c52ba6074133a2a701..0fc2f5072ff65bb5a99fe1e49d793f0eab434230 100644 (file)
@@ -9,18 +9,18 @@ DISTRO_TYPE = "debug"
 
 #PREFERRED_PROVIDER_gconf=gconf-dbus
 
-PREFERRED_VERSION_libmatchbox = "1.7"
+PREFERRED_VERSION_libmatchbox = "1.7cvs${CVSDATE}"
 PREFERRED_VERSION_matchbox = "0.9.1"
-PREFERRED_VERSION_matchbox-common = "0.9.1"
-PREFERRED_VERSION_matchbox-desktop = "0.9.1"
-PREFERRED_VERSION_matchbox-wm = "svn"
-PREFERRED_VERSION_matchbox-panel = "0.9.2"
+PREFERRED_VERSION_matchbox-common = "0.9.1cvs${CVSDATE}"
+PREFERRED_VERSION_matchbox-desktop = "0.9.1cvs${CVSDATE}"
+PREFERRED_VERSION_matchbox-wm = "0.9.5cvs${CVSDATE}"
+PREFERRED_VERSION_matchbox-panel = "0.9.2cvs${CVSDATE}"
 PREFERRED_VERSION_matchbox-applet-inputmanager = "0.6"
 
 PREFERRED_VERSION_atk = "1.10.0"
 PREFERRED_VERSION_cairo = "1.0.0"
 PREFERRED_VERSION_glib-2.0 = "2.8.1"
-PREFERRED_VERSION_gtk+ = "2.8.3"
+PREFERRED_VERSION_gtk+ = "2.6.7"
 PREFERRED_VERSION_pango = "1.10.0"
 
-PREFERRED_VERSION_dbus = "0.36"
+PREFERRED_VERSION_dbus = "0.50"
index cacd461a177a6182b04d014d2d0fb431dc70ac71..b54109580d52e1ccc09b7491784171c1839770d1 100644 (file)
@@ -3,14 +3,15 @@ SECTION = "x11/gnome"
 DESCRIPTION = "GNOME configuration database system"
 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.6/GConf-${PV}.tar.bz2 \
           file://backends.patch;patch=1"
-DEPENDS = "orbit2 glib-2.0  libxml2"
+DEPENDS = "orbit2 glib-2.0  libxml2 gtk+"
 ORBIT_IDL_SRC = "${STAGING_BINDIR}/orbit-idl-2"
 
 FILES_${PN} += " ${libdir}/GConf/*"
+PR = "r1"
 
 S = "${WORKDIR}/GConf-${PV}"
 
-EXTRA_OECONF = "--disable-gtk-doc"
+EXTRA_OECONF = "--disable-gtk-doc --enable-gtk"
 
 inherit autotools pkgconfig gettext
 
index dbd4edc860831315fc6c88df9bb2a7f1368e8237..6b8704e4d9fe1287c23c30dafb8a2b7977aed977 100644 (file)
@@ -1,6 +1,6 @@
 include libmatchbox.inc
 
-PV = "1.6cvs${CVSDATE}"
+PV = "1.7cvs${CVSDATE}"
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http\
diff --git a/openembedded/packages/matchbox-common/matchbox-common_svn.bb b/openembedded/packages/matchbox-common/matchbox-common_svn.bb
new file mode 100644 (file)
index 0000000..de1e20b
--- /dev/null
@@ -0,0 +1,17 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager common files"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox"
+PV = "0.9.1cvs${CVSDATE}"
+S = "${WORKDIR}/matchbox-common"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-common;proto=http"
+
+inherit autotools  pkgconfig
+
+EXTRA_OECONF = "--enable-pda-folders"
+
+FILES_${PN} = "${bindir} \
+              ${datadir}/matchbox/vfolders \
+              ${datadir}/pixmaps"
index 9634c4960c40cc811d1459b8b8c4280e75bbf10f..ca193d42c19d8f16f67224d8213636a7f1eb67db 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Matchbox Window Manager Desktop"
 LICENSE = "GPL"
 DEPENDS = "libmatchbox startup-notification"
 SECTION = "x11/wm"
-PV = "0.9cvs${CVSDATE}"
+PV = "0.9.1cvs${CVSDATE}"
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
index 9d18c90aaed2c0c2eebf3ce645c976d74d4444af..c109084806e36bfbcc756136e9b9c04e66d3ecee 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Matchbox Window Manager Panel"
 LICENSE = "GPL"
 DEPENDS = "libmatchbox x11 xext xpm apmd startup-notification virtual/kernel"
 SECTION = "x11/wm"
-PV = "0.9cvs${CVSDATE}"
+PV = "0.9.2cvs${CVSDATE}"
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
index d74724374020d83b35be686ea88f4dc8aeb5f485..5ac11d212dcca6937192016614c02bce6cafed3d 100644 (file)
@@ -1,10 +1,10 @@
 SECTION = "x11/wm"
 DESCRIPTION = "Matchbox window manager"
 LICENSE = "GPL"
-DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common"
 RDEPENDS = "matchbox-common"
-PV = "0.9.5+cvs-${CVSDATE}"
-PR = "r1"
+PV = "0.9.5cvs${CVSDATE}"
+PR = "r2"
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
@@ -26,7 +26,7 @@ FILES_${PN} = "${bindir} \
                ${datadir}/themes/Default/matchbox \
                ${datadir}/themes/MBOpus/matchbox"
 
-EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm --enable-expat"
 
 do_install_prepend() {
        install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig