]> code.ossystems Code Review - openembedded-core.git/commitdiff
file: update to 5.09
authorSaul Wold <sgw@linux.intel.com>
Tue, 15 Nov 2011 20:58:40 +0000 (12:58 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Nov 2011 17:27:09 +0000 (17:27 +0000)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/file/file/fix_version_check.patch [new file with mode: 0644]
meta/recipes-devtools/file/file_5.09.bb [moved from meta/recipes-devtools/file/file_5.04.bb with 79% similarity]

diff --git a/meta/recipes-devtools/file/file/fix_version_check.patch b/meta/recipes-devtools/file/file/fix_version_check.patch
new file mode 100644 (file)
index 0000000..bd24ccb
--- /dev/null
@@ -0,0 +1,21 @@
+Since we are cross-compiling and need to have a cover script this
+version check sees "file.real-5.09" not "file-5.09", so fix the
+sed.
+
+Upstream-Status: Inapproriate [build-specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: file-5.09/magic/Makefile.am
+===================================================================
+--- file-5.09.orig/magic/Makefile.am
++++ file-5.09/magic/Makefile.am
+@@ -260,7 +260,7 @@ ${MAGIC}: $(EXTRA_DIST) $(FILE_COMPILE_D
+       @(if expr "${FILE_COMPILE}" : '.*/.*' > /dev/null; then \
+           echo "Using ${FILE_COMPILE} to generate ${MAGIC}" > /dev/null; \
+         else \
+-          v=$$(file --version | sed -e s/file-// -e q); \
++          v=$$(file --version | sed -e s/file.real-// -e q); \
+           if [ "$$v" != "${PACKAGE_VERSION}" ]; then \
+               echo "Cannot use the installed version of file ($$v) to"; \
+               echo "cross-compile file ${PACKAGE_VERSION}"; \
similarity index 79%
rename from meta/recipes-devtools/file/file_5.04.bb
rename to meta/recipes-devtools/file/file_5.09.bb
index 1f9c78eb7b61314bcdaee9455d8d524ba31ac683..9b2f3a42af5f43c88208718c70bc10a4d72c331f 100644 (file)
@@ -10,16 +10,15 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03
 
 DEPENDS = "zlib file-native"
 DEPENDS_virtclass-native = "zlib-native"
-PR = "r2"
+PR = "r0"
 
 SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
-           file://stringb-compat.patch \
-           file://ge-le.patch \
+           file://fix_version_check.patch \
            file://dump \
            file://filesystems"
 
-SRC_URI[md5sum] = "accade81ff1cc774904b47c72c8aeea0"
-SRC_URI[sha256sum] = "4c9e6e7994e74cb3386374ae91b055d26ac96b9d3e82fd157ae2d62e87a4260c"
+SRC_URI[md5sum] = "6fd7cd6c4281e68fe9ec6644ce0fac6f"
+SRC_URI[sha256sum] = "bde1c9830ee6c234871778faae8277fdcf775fbb16dea63c8251e24b7c2f869c"
 
 inherit autotools