]> code.ossystems Code Review - openembedded-core.git/commitdiff
btrfs-tools: fix for parallel build
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 18 Feb 2015 03:28:42 +0000 (19:28 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Feb 2015 07:50:44 +0000 (07:50 +0000)
Fixed:
mkfs.c:300:46: error: 'BTRFS_BUILD_VERSION' undeclared (first use in this function)
  fprintf(stderr, "mkfs.btrfs, part of %s\n", BTRFS_BUILD_VERSION);

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/btrfs-tools/btrfs-tools/fix-parallel.patch [new file with mode: 0644]
meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb

diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix-parallel.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix-parallel.patch
new file mode 100644 (file)
index 0000000..65c31a4
--- /dev/null
@@ -0,0 +1,32 @@
+From 373eb51328b5e10529763cad441210e6b0efb24e Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Wed, 11 Feb 2015 22:08:41 -0800
+Subject: [PATCH] Makefile: fix for parallel build
+
+Fixed:
+mkfs.c:300:46: error: 'BTRFS_BUILD_VERSION' undeclared (first use in this function)
+  fprintf(stderr, "mkfs.btrfs, part of %s\n", BTRFS_BUILD_VERSION);
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 9c69ada..30c6f06 100644
+--- a/Makefile
++++ b/Makefile
+@@ -118,7 +118,7 @@ else
+       AM_CFLAGS += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+ endif
+-%.o.d: %.c
++%.o.d: %.c version.h
+       $(Q)$(CC) -MM -MG -MF $@ -MT $(@:.o.d=.o) -MT $(@:.o.d=.static.o) -MT $@ $(AM_CFLAGS) $(CFLAGS) $<
+ .c.o:
+-- 
+1.7.9.5
+
index f796f6f85a85ede269465e7d1b593c1d6157c132..d86075c4c622a70e0c79acde5fbf40fab483df28 100644 (file)
@@ -13,7 +13,10 @@ SECTION = "base"
 DEPENDS = "util-linux attr e2fsprogs lzo acl"
 
 SRCREV = "344599a7aefe23c7169ccdde3ad1b921bb60024c"
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
+           file://fix-parallel.patch \
+"
+
 S = "${WORKDIR}/git"
 
 PV = "3.18.2+git${SRCPV}"