]> code.ossystems Code Review - openembedded-core.git/commitdiff
usbpath: added from OE (needed for dfu-util)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 5 Nov 2007 15:48:15 +0000 (15:48 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 5 Nov 2007 15:48:15 +0000 (15:48 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3067 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta-openmoko/packages/usbpath/usbpath-native_svn.bb [new file with mode: 0644]
meta-openmoko/packages/usbpath/usbpath_svn.bb [new file with mode: 0644]

diff --git a/meta-openmoko/packages/usbpath/usbpath-native_svn.bb b/meta-openmoko/packages/usbpath/usbpath-native_svn.bb
new file mode 100644 (file)
index 0000000..3b5ef7b
--- /dev/null
@@ -0,0 +1,8 @@
+require usbpath_svn.bb
+inherit native
+DEPENDS = "libusb-native"
+
+do_stage () {
+       autotools_stage_all
+}
+
diff --git a/meta-openmoko/packages/usbpath/usbpath_svn.bb b/meta-openmoko/packages/usbpath/usbpath_svn.bb
new file mode 100644 (file)
index 0000000..0a06477
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "Convert the physical locations of a USB device to/from its number"
+AUTHOR = "Werner Almesberger <werner@openmoko.org>"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "libusb"
+
+PV = "0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host;module=usbpath;proto=http"
+
+S = "${WORKDIR}/usbpath"
+
+inherit autotools
+
+do_stage () {
+       autotools_stage_all
+}
+