]> code.ossystems Code Review - openembedded-core.git/commitdiff
kconfig-frontends: Create symlinks for conf and mconf
authorKhem Raj <raj.khem@gmail.com>
Thu, 6 Sep 2012 22:20:36 +0000 (15:20 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 10 Sep 2012 11:07:44 +0000 (12:07 +0100)
eglibc calls out mconf and conf directly so lets create
symlinks to point to their kconfig- counterparts

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.5.bb

index 277de03200dd1d367c834da71638bd2b6d2366d6..96899b842be12d52c80b372a7f6e6fce05491334 100644 (file)
@@ -11,7 +11,7 @@ LICENSE = "GPL-2.0"
 LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
 SECTION = "devel"
 DEPENDS += "ncurses flex bison gperf"
-PR = "r0"
+PR = "r1"
 PV = "3.5.0"
 SPIN = "0"
 SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}-${SPIN}.tar.xz"
@@ -24,6 +24,12 @@ inherit autotools
 do_configure_prepend () {
        mkdir -p scripts/.autostuff/m4
 }
+
+do_install_append() {
+       ln -s kconfig-conf ${D}${bindir}/conf
+       ln -s kconfig-mconf ${D}${bindir}/mconf
+}
+
 EXTRA_OECONF += "--disable-gconf --disable-qconf"
 
 # Some packages have the version preceeding the .so instead properly