]> code.ossystems Code Review - openembedded-core.git/commitdiff
[xf86-video-intel-dri2] Updates 004_reduce_driver_boottime.patch
authorRobert Bragg <robert@linux.intel.com>
Wed, 29 Oct 2008 18:33:27 +0000 (18:33 +0000)
committerRobert Bragg <robert@linux.intel.com>
Thu, 30 Oct 2008 18:26:05 +0000 (18:26 +0000)
meta/packages/xorg-driver/xf86-video-intel-dri2/004_reduce_driver_boottime.patch
meta/packages/xorg-driver/xf86-video-intel-dri2_git.bb

index 97921223d0b344ee417f6ca9207a78943bd9c684..3f8c5c7bdeb803eefcc0dd85025487dbad4a8de1 100644 (file)
@@ -1,8 +1,8 @@
-diff --git a/src/i830_display.c b/src/i830_display.c
-index 95ce51e..2c49b43 100644
---- a/src/i830_display.c
-+++ b/src/i830_display.c
-@@ -376,7 +376,7 @@ void
+Index: git/src/i830_display.c
+===================================================================
+--- git.orig/src/i830_display.c        2008-10-29 15:46:24.000000000 +0000
++++ git/src/i830_display.c     2008-10-29 18:27:47.000000000 +0000
+@@ -376,7 +376,7 @@
  i830WaitForVblank(ScrnInfoPtr pScreen)
  {
      /* Wait for 20ms, i.e. one cycle at 50hz. */
@@ -11,59 +11,3 @@ index 95ce51e..2c49b43 100644
  }
  
  void
-diff --git a/src/i830_driver.c b/src/i830_driver.c
-index 6cd30b2..223967f 100644
---- a/src/i830_driver.c
-+++ b/src/i830_driver.c
-@@ -2303,7 +2303,7 @@ SaveHWState(ScrnInfoPtr pScrn)
- static void
- i830_dpll_settle(void)
- {
--    usleep(10000); /* 10 ms *should* be plenty */
-+    usleep(150); /* 10 ms *should* be plenty */
- }
- static Bool
-@@ -2325,14 +2325,12 @@ RestoreHWState(ScrnInfoPtr pScrn)
-       xf86OutputPtr   output = xf86_config->output[i];
-       output->funcs->dpms(output, DPMSModeOff);
-    }
--   i830WaitForVblank(pScrn);
-    
-    /* Disable pipes */
-    for (i = 0; i < xf86_config->num_crtc; i++) {
-       xf86CrtcPtr crtc = xf86_config->crtc[i];
-       crtc->funcs->dpms(crtc, DPMSModeOff);
-    }
--   i830WaitForVblank(pScrn);
-    if (IS_MOBILE(pI830) && !IS_I830(pI830))
-       OUTREG(LVDS, pI830->saveLVDS);
-@@ -2422,13 +2420,11 @@ RestoreHWState(ScrnInfoPtr pScrn)
-        DISPPLANE_SEL_PIPE_A) {
-        OUTREG(DSPACNTR, pI830->saveDSPACNTR);
-        OUTREG(DSPABASE, INREG(DSPABASE));
--       i830WaitForVblank(pScrn);
-    }
-    if ((pI830->saveDSPBCNTR & DISPPLANE_SEL_PIPE_MASK) ==
-        DISPPLANE_SEL_PIPE_A) {
-        OUTREG(DSPBCNTR, pI830->saveDSPBCNTR);
-        OUTREG(DSPBBASE, INREG(DSPBBASE));
--       i830WaitForVblank(pScrn);
-    }
-    /* See note about pipe programming above */
-@@ -2484,13 +2480,11 @@ RestoreHWState(ScrnInfoPtr pScrn)
-         DISPPLANE_SEL_PIPE_B) {
-         OUTREG(DSPACNTR, pI830->saveDSPACNTR);
-         OUTREG(DSPABASE, INREG(DSPABASE));
--        i830WaitForVblank(pScrn);
-       }
-       if ((pI830->saveDSPBCNTR & DISPPLANE_SEL_PIPE_MASK) ==
-         DISPPLANE_SEL_PIPE_B) {
-         OUTREG(DSPBCNTR, pI830->saveDSPBCNTR);
-         OUTREG(DSPBBASE, INREG(DSPBBASE));
--        i830WaitForVblank(pScrn);
-       }
-    }
index 24e03c876565e1d63daacd70c72f002e35b5f1c2..2ac57cc4ecd64539378c8cc05fb0ccdc5b8c734b 100644 (file)
@@ -6,15 +6,14 @@ DEPENDS += "virtual/libx11 libxvmc drm dri2proto glproto \
 PROVIDES = "xf86-video-intel"
 
 PE = "1"
-PR = "r1"
+PR = "r2"
 PV = "2.4.97.0+git${SRCREV}"
 
 FILESPATH = "${FILE_DIRNAME}/xf86-video-intel"
 
-#FIXME: update patch
-#file://004_reduce_driver_boottime.patch;patch=1
 SRC_URI = "git://anongit.freedesktop.org/git/xorg/driver/xf86-video-intel;protocol=git;branch=dri2 \
            file://002_avoid_duplicate_SaveHWState.patch;patch=1 \
+           file://004_reduce_driver_boottime.patch;patch=1 \
            file://005_disable_sdvo_TV_port_restoreHW.patch;patch=1 \
            file://006_disable_check_lvds_panelpower_status.patch;patch=1"