]> code.ossystems Code Review - openembedded-core.git/commitdiff
beecrypt: add option --with-dev-dsp
authorKai Kang <kai.kang@windriver.com>
Wed, 29 Oct 2014 11:16:07 +0000 (19:16 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Nov 2014 15:36:12 +0000 (15:36 +0000)
Add this configure option for developer to control if the
/dev/dsp should be used on target. Instead of judging it
based on the very device file of build server.

Signed-off-by: Zhang Xiao <xiao.zhang@windriver.com>
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/beecrypt/beecrypt/add-option-dev-dsp.patch [new file with mode: 0644]
meta/recipes-support/beecrypt/beecrypt_4.2.1.bb

diff --git a/meta/recipes-support/beecrypt/beecrypt/add-option-dev-dsp.patch b/meta/recipes-support/beecrypt/beecrypt/add-option-dev-dsp.patch
new file mode 100644 (file)
index 0000000..b3298ce
--- /dev/null
@@ -0,0 +1,34 @@
+Add config option --with-dev-dsp.
+
+Upstream-Status: Pending
+
+Signed-off-by: Zhang Xiao <xiao.zhang@windriver.com>
+---
+--- a/configure.ac
++++ b/configure.ac
+@@ -106,6 +106,16 @@ AC_ARG_WITH(python,[  --with-python[[=AR
+   fi
+   ])
++AC_ARG_WITH(dev-dsp,[  --with-dev-dsp          enables dev/dsp for entropy producing. auto for auto-detecting dev/dep on host. [[default=no]]],[
++  if test "$withval" = yes; then
++    AC_DEFINE([HAVE_DEV_DSP], 1)
++  else
++    if test "$withval" = auto;  then
++      ac_detect_dev_dsp=yes
++    fi
++  fi
++  ],[ac_detect_dev_dsp=no])
++
+ # Check for expert mode
+ if test "$ac_enable_expert_mode" = yes; then
+   BEE_EXPERT_MODE
+@@ -464,7 +474,7 @@ linux*)
+       ac_cv_have_dev_dsp=no
+     fi
+     ])
+-  if test "$ac_cv_have_dev_dsp" = yes; then
++  if test "$ac_cv_have_dev_dsp" = yes && test "$ac_detect_dev_dsp" = yes; then
+     AC_DEFINE([HAVE_DEV_DSP], 1)
+   fi
+   ;;
index 209b92e653002136f8c76c23f20ef779c621e9ae..1e626f154c2bb6d665a9f1ca0a8fab361afdf870 100644 (file)
@@ -11,6 +11,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
            file://fix-for-gcc-4.7.patch \
            file://run-ptest \
            file://beecrypt-enable-ptest-support.patch \
+           file://add-option-dev-dsp.patch \
           "
 
 SRC_URI[md5sum] = "8441c014170823f2dff97e33df55af1e"