]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add packages for Contacts 0.1 and svn
authorChris Lord <chris@openedhand.com>
Thu, 22 Dec 2005 16:50:56 +0000 (16:50 +0000)
committerChris Lord <chris@openedhand.com>
Thu, 22 Dec 2005 16:50:56 +0000 (16:50 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@203 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/contacts/contacts_0.1.bb [moved from openembedded/packages/contacts/contacts_0.0.bb with 89% similarity]
openembedded/packages/contacts/contacts_svn.bb [new file with mode: 0755]

similarity index 89%
rename from openembedded/packages/contacts/contacts_0.0.bb
rename to openembedded/packages/contacts/contacts_0.1.bb
index ef2d1b1b93c8b663e74c8e989b617037626091df..aff86a1c65ce4e40caa263a7334e820318316e00 100755 (executable)
@@ -3,15 +3,16 @@ SECTION = "x11"
 DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Contacts is an address-book application."
-PR = "r5"
 
-SRC_URI = "file:///tmp/${PN}-${PV}.tar.gz \
+SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \
           file://stock_contact.png \
           file://stock_person.png \
           file://index.theme"
 
 inherit autotools pkgconfig
 
+S = "${WORKDIR}/release-0.1"
+
 do_install_append () {
        install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
        install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
diff --git a/openembedded/packages/contacts/contacts_svn.bb b/openembedded/packages/contacts/contacts_svn.bb
new file mode 100755 (executable)
index 0000000..121f256
--- /dev/null
@@ -0,0 +1,36 @@
+LICENSE = "LGPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade eds-dbus gnome-vfs"
+RDEPENDS = "gnome-vfs-plugin-file"
+RRECOMMENDS = "gnome-vfs-plugin-http"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+DESCRIPTION = "Contacts is an address-book application."
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
+          file://stock_contact.png \
+          file://stock_person.png \
+          file://index.theme"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--enable-gnome-vfs"
+
+do_install_append () {
+       install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
+       install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+
+       install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
+       install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+       install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+}
+
+FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
+               ${datadir}/icons/hicolor/48x48/stock/*/*.png \
+               ${datadir}/icons/hicolor/index.theme"
+
+pkg_postinst_${PN} () {
+       gtk-update-icon-cache /usr/share/icons/hicolor
+}
+