]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsbtest: add ppc64 support
authorKai Kang <kai.kang@windriver.com>
Thu, 12 Dec 2013 02:36:28 +0000 (10:36 +0800)
committerSaul Wold <sgw@linux.intel.com>
Tue, 17 Dec 2013 17:05:15 +0000 (09:05 -0800)
LSB supports to test on PPC64 target, so update lsbtest recipe and test
scripts to enable PPC64 support.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
meta/recipes-extended/lsb/lsbtest_1.0.bb

index 37ce3f150a4053c24de3492a97c0765000f5c03b..12f00547ae3e16a299f69f975dfafc3979f64622 100644 (file)
@@ -29,7 +29,7 @@ EOF
 fi
 
 ARCH=`uname -m`
-if [ ${ARCH} != "i686" ] && [ ${ARCH} != "x86_64" ] && [ ${ARCH} != "ppc" ]
+if [ ${ARCH} != "i686" ] && [ ${ARCH} != "x86_64" ] && [ ${ARCH} != "ppc" ] && [ ${ARCH} != "ppc64" ]
 then
        echo "Error: Unsupported architecture"
        exit 1
index 8973e094e5739d1e1e8e7dcb163f30b9bad7adbc..520c1e79bd306701068ed28df81fa8d30aaf7b88 100644 (file)
@@ -31,6 +31,18 @@ do_install() {
                sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
                sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
        fi
+
+       # For a ppc64 target. the default userspace is 32b.
+       # Therefore, only change the lsbarch and targetarch
+       # in the package_list when MLIB=lib64 is being used.
+       # Otherwise, by default, the ppc32 LSB packages
+       # will be downloaded by LSB_Test.sh
+       if [ "${TARGET_ARCH}" == "powerpc64" ];then
+               if [ "${PN}" != "${BPN}" ];then
+                       sed -i -e 's/lsbarch/ppc64/g' -e 's/targetarch/ppc64/g' ${D}/opt/lsb-test/packages_list
+                       sed -i -e 's/targetarch/PPC64/g' ${D}/opt/lsb-test/session
+               fi
+       fi
 }
 
 FILES_${PN} += "/opt/lsb-test/* \