]> code.ossystems Code Review - openembedded-core.git/commitdiff
kconfig-frontends: fix build race
authorRoss Burton <ross.burton@intel.com>
Tue, 9 May 2017 14:33:47 +0000 (15:33 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 23 May 2017 16:43:58 +0000 (17:43 +0100)
In parallel builds utils/kconfig-tweak may be written to before utils/ exists,
so add a mkdir.

Also mark the pkgconfig patch as Submitted as I sent that upstream at the same
time.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/kconfig-frontends/files/0001-Fix-installation-of-.pc-files.patch
meta/recipes-devtools/kconfig-frontends/files/missing-mkdir.patch [new file with mode: 0644]
meta/recipes-devtools/kconfig-frontends/kconfig-frontends_4.10.0.1.bb

index e9195a0afcd0e83081ac5def49c6ff1d6c060163..57ea42e4b28a7fe8b3812325c665325ae0725efb 100644 (file)
@@ -5,7 +5,7 @@ Subject: [PATCH] Fix installation of .pc files
 
 They go to prefix/pkgconfig/, not prefix/pkg-config.
 
-Upstream-Status: Pending
+Upstream-Status: Submitted
 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
 ---
  Makefile.am | 2 +-
@@ -26,4 +26,3 @@ index 058690a..f9e9b7b 100644
  EXTRA_DIST += libs/parser/kconfig-parser.pc.in
 -- 
 2.11.0
-
diff --git a/meta/recipes-devtools/kconfig-frontends/files/missing-mkdir.patch b/meta/recipes-devtools/kconfig-frontends/files/missing-mkdir.patch
new file mode 100644 (file)
index 0000000..a06a547
--- /dev/null
@@ -0,0 +1,33 @@
+Upstream-Status: Submitted
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From ca05ee2fb6db5b3b1edc16dba6150a2c6078a6cf Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Tue, 9 May 2017 15:30:00 +0100
+Subject: [PATCH] Makefile: ensure utils/ exists before writing to it
+
+Since utils/ was changed to not build recursively it's possible that in
+out-of-tree builds the utils/ directory hasn't been created when Make runs the
+utils/kconfig-tweak target which tries to write to file inside utils/.
+
+To ensure this can work, mkdir the directory.
+
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+---
+ Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index c8e96ef..1baa110 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -348,6 +348,7 @@ EXTRA_DIST += \
+       utils/kconfig-tweak.in.patch
+ utils/kconfig-tweak: utils/kconfig-tweak.in
++      $(MKDIR_P) $(@D)
+       $(AM_V_GEN)$(SED) -e "s/@CONFIG_@/$(config_prefix)/g" \
+               $< >$@
+       @chmod +x $@
+-- 
+2.8.1
index be90d6b88033d26b787d319c51f8d1121d76c699..d427e98c916405d748138f2c2a518f35efc5f278 100644 (file)
@@ -15,7 +15,8 @@ DEPENDS += "ncurses flex bison gperf-native"
 RDEPENDS_${PN} += "python3 bash"
 SRC_URI = "git://ymorin.is-a-geek.org/kconfig-frontends;branch=4.10.x \
            file://0001-Fix-installation-of-.pc-files.patch \
-           file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch"
+           file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch \
+           file://missing-mkdir.patch"
 
 SRCREV = "f8ffe5e1c6f183cb7d5d515aa9381b7557de654e"